Project

General

Profile

Bug #3982

Installer generates errors when selecting "Embedded" but still appears to work

Added by Jim Pingle over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Ermal Luçi
Category:
Installer
Target version:
Start date:
11/04/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

When running the installer and choosing "Embedded" two errors are given by the GUI but if "skip" is chosen the install proceeds and appears to work afterward.

Flow executing -> main/install/install_kernel (Install Kernel)
[Tue Nov 4 13:52:51 2014]
,-<<< Executing `tar xzpf /kernels/kernel_*wrap*.gz -C /mnt/boot/'
| tar: Error opening archive: Failed to open
'/kernels/kernel_*wrap*.gz'
`->>> Exit status: 1
[Tue Nov 4 13:53:47 2014]
,-<<< Executing `test -f /etc/ttys_wrap && cp /etc/ttys_wrap
/mnt/etc/ttys'
`->>> Exit status: 1

The ttys_wrap file and the wrap kernel no longer exist on 2.2. The correct console settings are active in loader.conf and the serial console does work after installation. The installer code to run those two obsolete commands should be cleaned up.

Marking as RC blocking since it's a common case and ugly but ultimately should be easy to fix so users don't get scared away before it even installs.

History

#1 Updated by Chris Buechler over 5 years ago

  • Status changed from New to Confirmed

#2 Updated by Jim Pingle over 5 years ago

An additional note after talking to Renato earlier and doing some research:

The serial console worked for me because I used the serial memstick to install. The serial memstick's default config has "<enableserial/>" injected by the builder when it is created.

If someone restores a config without enableserial, it would lose access to its console, so the choice here should setup the target disk in some way to retain the serial setting by some variation of using enableserial_force.

#3 Updated by Ermal Luçi over 5 years ago

The issue here is that the amd64 builds do not have anymore the wrap kernels.
Only i386 has this type of kernel.

This is quite visible on the generate config logs from the builders.
From i386 snapshot builder:
Fri Nov 7 00:12:15 CST 2014 |- BUILD_KERNELS: pfSense_SMP.10
Fri Nov 7 00:12:15 CST 2014 -|
BUILD_KERNELS: pfSense_wrap.10.i386
Fri Nov 7 00:12:15 CST 2014 -|- BUILD_KERNELS: pfSense_wrap_vga.10.i386

From amd64 snapshot builders:
Fri Nov 7 00:15:45 CST 2014 -|- BUILD_KERNELS: pfSense_SMP.10

The real fix is just to skip the kernel selection menu for amd64 and just deploy the generic kernel(and the only availble) from /kernels.

Not sure if this check should be done on the installer or have a separate installer config for amd64 and i386!

#4 Updated by Jim Pingle over 5 years ago

Even with only one kernel a choice must still be made about the console, so changing this screen into a console selection rather than kernel selection is probably better. Otherwise people will very easily lose access to their system consoles on hardware without a VGA port.

#5 Updated by Ermal Luçi over 5 years ago

Isn;t memstick just a loader.conf option kernel rather than else on amd64?

#6 Updated by Ermal Luçi over 5 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Ermal Luçi

Solution put in place for having this working on 2.2 and 64bit installer.

#7 Updated by Renato Botelho over 5 years ago

ttys_wrap file was removed on 2.2, but is still necessary o 2.1. Would be better if installer guess pfSense version based on FreeBSD version.

#8 Updated by Ermal Luçi over 5 years ago

I have corrected this on new snapshots.

#9 Updated by Chris Buechler over 5 years ago

  • Status changed from Feedback to Resolved

fixed

#10 Updated by Jim Pingle over 5 years ago

The error is fixed but the console problem I mentioned above is still an issue. I moved it to #4009

Also available in: Atom PDF