Project

General

Profile

Bug #4084

Check_mk agent doesn't work: wrong bash path

Added by Flavio Stanchina almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/09/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.1.5
Affected Architecture:

Description

The official Check_mk agent package doesn't work because the shebang line at the top of /usr/local/bin/check_mk_agent is wrong: it needs to be #!/usr/local/bin/bash, not #!/bin/bash.

History

#1 Updated by Peter Baumann over 4 years ago

The Problem is that with 2.2-RELEASE bash is not there anymore so check_mk_agent will not work.
After installing bash with pkg I had to change the shebang to #!/usr/local/bin/bash. So the package needs to be fixed.

#2 Updated by Peter Baumann over 4 years ago

I found a solution to the problem.
Since the check_mk pfSense Package is downloading the latest check_mk_agent.freebsd (1.2.7i1) it needs bash to work which is not installed on pfSense anymore.
I tried now the stable release of the check_mk_agent which is version 1.2.6 which is working well and using /bin/sh.

So is it possible for the check_mk_agent package maintainer to use the 1.2.6 version of the agent?

Many thanks!

#4 Updated by Renato Botelho over 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Pull request has been merged

#5 Updated by Kill Bill about 4 years ago

Fixed.

#6 Updated by Chris Buechler about 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF