Project

General

Profile

Actions

Bug #417

closed

Packages don't install on embedded

Added by Oscar Francia over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
Start date:
03/10/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

Downloading package configuration file... done.
Saving updated package information... done.
Downloading OpenVPN Client Export Utility and its dependencies... done.
Checking for successful package installation... of p7zip-9.04 failed!

Installation aborted.

Actions #1

Updated by Oscar Francia over 11 years ago

All packages fail to install! :(

Actions #2

Updated by Chris Buechler over 11 years ago

  • Status changed from New to Feedback

They all work for me including the client export, on a gitsync as of 10 minutes ago. Maybe a connectivity issue on your system preventing the downloads?

Actions #3

Updated by Oscar Francia over 11 years ago

I've tested package installation for 2-3 days in 2 different adsl line and 3 different alix board...
Now I've only lan with gateway. Embedded image 512Mb 10.03.2010.
I can't see errors on log files :(

Actions #4

Updated by Chris Buechler over 11 years ago

  • Subject changed from Error when installing package OpenVPN Client Export Utility to Packages don't install on embedded
  • Status changed from Feedback to New

Probably a mount ro/rw issue on embedded, though I haven't confirmed.

Actions #5

Updated by Oscar Francia over 11 years ago

Yes, only embedded, iso works fine

Actions #6

Updated by Scott Ullrich over 11 years ago

Try again in about 15 minutes. I just committed a fix for the openvpn-client-export case but there are surely more packages that have this issue as well that should be looked at.

Actions #7

Updated by Andy L over 11 years ago

Scott Ullrich wrote:

Try again in about 15 minutes. I just committed a fix for the openvpn-client-export case but there are surely more packages that have this issue as well that should be looked at.

FYI, I just tried imspector, lcdproc, bandwidthd and snortdev with no success. 2g-nano updated to 3/9/10.

Actions #8

Updated by Oscar Francia over 11 years ago

Same error with clean image :(

Actions #9

Updated by Dave Sanderson over 11 years ago

It appears to be a read-only mount issue on the embedded image.

I tested this using LCDProc and I was able to get the package to install after looping the remount of / as rw from the shell during install.

Actions #10

Updated by Andy L over 11 years ago

Dave Sanderson wrote:

It appears to be a read-only mount issue on the embedded image.

I tested this using LCDProc and I was able to get the package to install after looping the remount of / as rw from the shell during install.

I just attempted this. Mounted as rw via shell and tried LCDProc with no success on the 1G embedded dated 3-14.

Actions #11

Updated by Dave Sanderson over 11 years ago

I looked into this again after Andy had it failed. It appears my loop of mount -o rw /dev/ufs/pfsense0 / only worked because it happened that right time, being after the package downloaded and before the install.

After digging through everything is I've found that adding conf_mount_rw(); to /etc/inc/pkg-utils.php before line 406, corrects the issue and allows packages to install.

406: conf_mount_rw();
407: exec("cat {$g['tmp_path']}/y | /usr/sbin/pkg_add -fv {$fetchto} 2>&1", $pkgaddout);

Actions #12

Updated by Erik Fonnesbeck over 11 years ago

Does it get remounted in the proper read-only state afterward?

Actions #13

Updated by Dave Sanderson over 11 years ago

Yes, after the install the disk gets remounted in a read-only state.

Actions #14

Updated by Peter Baumann over 11 years ago

I figured out you need another conf_mount_rw(); if you install as example OpenVPN Export Utility. This Package installs additional p7zip and zip packages.

I could manage to install these packages with the following in /etc/inc/pfsense-utils.inc

1553         conf_mount_rw();
1554 $fout = fopen($destination_file, "wb");

Greetings

Peter

Actions #15

Updated by Ermal Luçi over 11 years ago

  • Status changed from New to Feedback
Actions #16

Updated by Oscar Francia over 11 years ago

On last build ( tested on pfSense-2.0-BETA1-1g-20100322-0920-nanobsd ) works!

Tnx

Actions #17

Updated by Chris Buechler over 11 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF