Project

General

Profile

Bug #4238

Firewall rule: source port display issue

Added by Anonymous over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
01/19/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

Hello,
it is a display issue and appears when i try to select saved aliases on source port range.
The red background is partially displayed on suggested aliases making difficult to choose.
This not happens when i select aliases on destination port field.
I have attached a screenshot to better understanding the issue.
Thanks for support

pfsense_sourceport_issue.jpg (43.1 KB) pfsense_sourceport_issue.jpg Anonymous, 01/19/2015 01:56 AM

Associated revisions

Revision 6672609b (diff)
Added by Renato Botelho over 5 years ago

Fix aliases popup width when fields are hidden when page is loaded. It should fix #4238

Revision 4520b2d2 (diff)
Added by Renato Botelho over 5 years ago

Fix aliases popup width when fields are hidden when page is loaded. It should fix #4238

History

#1 Updated by Chris Buechler over 5 years ago

  • Category changed from Rules / NAT to Web Interface
  • Target version changed from 2.2 to 2.2.1

#3 Updated by Anonymous over 5 years ago

the fetch fails
i suppose that a / is missing on the patch

usr/local/www/firewall_rules_edit.php

Regards

#5 Updated by Bipin Chandra over 5 years ago

the above link is the patch file but u can simply edit the page (/usr/local/www/firewall_rules_edit.php) by going to diahnostics->edit file and opening that file thens earching for style="display:none" and removing it

#6 Updated by Anonymous over 5 years ago

Thanks,
after removing style="display:none" id="sprtable" the cosmetic issue is not present anymore.

#7 Updated by Anonymous over 5 years ago

ben kenobi wrote:

Thanks,
after removing style="display:none" the cosmetic issue is not present anymore.

#8 Updated by Bipin Chandra over 5 years ago

after its merged, this can be closed

#9 Updated by Anonymous over 5 years ago

i noted also that the issue is present also for nat rules (port forwarding)

#10 Updated by Bipin Chandra over 5 years ago

i checked and doesnt seem any issue in port forwarding ports, try clearing your browser cache and check again and if it still persists then send in a screenshot

#11 Updated by Anonymous over 5 years ago

Bipin Chandra wrote:

i checked and doesnt seem any issue in port forwarding ports, try clearing your browser cache and check again and if it still persists then send in a screenshot

You are right. It was the browser cache

#12 Updated by Renato Botelho over 5 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#14 Updated by Chris Buechler about 5 years ago

  • Status changed from Feedback to Resolved

fixed

#15 Updated by Giuanin Piemunteis about 5 years ago

Chris Buechler wrote:

fixed

with the latest version i noted the issue is back and also is present in the destionation port field

#16 Updated by Bipin Chandra about 5 years ago

seems fine for me, clear ur browser cache and retry

Also available in: Atom PDF