Project

General

Profile

Bug #4327

Package Manager issue behind proxy

Added by Anonymous over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Package System
Target version:
Start date:
01/28/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

Hello,
the pfsense that i have installed inside my company uses proxy connections to get updates from pfsense sites.
I noted that package manager is not able to get the available packages or to retreive the last versions for the packages previously installed.
on the "available packages" i have this error message
"Unable to communicate with https://packages.pfsense.org. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

In the main dashboard is also reported a crash which shows this message
PHP Errors:
[26-Jan-2015 07:12:48 Europe/Rome] HTTP error, got response: HTTP/1.0 400 Bad Request

Whith a packet capture i saw that a POST to packages.pfsense.org is the cause

5 07:08:41.038470 10.10.45.110 10.45.5.50 HTTP/XML 81 8080 39551 POST https://packages.pfsense.org:443/xmlrpc.php HTTP/1.0
8 07:08:41.360524 10.45.5.50 10.10.45.110 HTTP 523 39551 8080 HTTP/1.0 400 Bad Request (text/html)

This not happens for release updates.

A workaround is to replace https://packages.pfsense.org with http://packages.pfsense.org on /etc/inc/globals.inc but maybe is better to notify you this issue if it should be solved for next releases
Regards
Guido

History

#1 Updated by Renato Botelho about 4 years ago

  • Status changed from New to Feedback

I couldn't replicate it. It authenticate on the proxy and get packages list without any problems.

#2 Updated by Chris Buechler about 4 years ago

  • Target version changed from 2.2.1 to 2.2.2

#3 Updated by Chris Buechler about 4 years ago

same here but will leave for feedback for now.

#4 Updated by Chris Buechler about 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#5 Updated by Chris Buechler almost 4 years ago

  • Target version changed from 2.2.3 to 2.3

#6 Updated by Jim Thompson over 3 years ago

  • Status changed from Feedback to Closed
  • Assignee set to Chris Buechler

I don't believe this was ever a (general) problem. It's been in feedback for 8 months. Assigning to cmb, and marking it 'Closed'.

If it comes back up, cmb to investigate.

#7 Updated by Chris Buechler about 3 years ago

  • Affected Version changed from 2.2 to 2.2.x

Also available in: Atom PDF