Project

General

Profile

Actions

Bug #4740

open

Intel wireless kernel panic in infrastructure mode with WPA

Added by Vladimir Chernyshov over 6 years ago. Updated 11 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Wireless
Target version:
-
Start date:
06/03/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2.x
Affected Architecture:
All

Description

I've got permanent kernel panic and reboot with intel wireless 4965 minipcie card in WAN infrastructure mode when wpa is activated.

It seems to me the reason is absence of timeout after wpa_supplicant is started, at least the patch below helped me

--- /etc/inc/interfaces.inc.orig 2015-06-03 14:32:10.000000000 0300
++ /etc/inc/interfaces.inc 2015-06-03 14:33:01.000000000 +0300
@ -2714,9 +2714,9 @
unset($wlcmd_args, $wlcmd);

- sleep(1);
/* execute hostapd and wpa_supplicant if required in shell */
mwexec("/bin/sh {$g['tmp_path']}/" . escapeshellarg($if) . "_setup.sh");
+ sleep(1);

return 0;
Actions #1

Updated by Chris Buechler almost 6 years ago

  • Subject changed from intel wireless 4965 kernel panic to Intel wireless kernel panic in infrastructure mode with WPA
  • Affected Version changed from 2.2.2 to 2.2.x
Actions #2

Updated by Chris Buechler almost 6 years ago

  • Affected Architecture All added
  • Affected Architecture deleted (amd64)
Actions #3

Updated by Ramon Buckland almost 6 years ago

Yes, moving the sleep(1) line from above to below the wpa_supplicant loading line resolved the issue.

I now have pfsense using WiFi as the WLAN link.

Actions #4

Updated by Renato Botelho 11 months ago

Considering all big FreeBSD changes since 2.2.x I must ask. Is it still happening on current versions?

Actions

Also available in: Atom PDF