Project

General

Profile

Bug #5081

LADVD failing on LAGG INTERFACE

Added by Evelio Vila over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
ladvd
Target version:
Start date:
09/02/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

Maybe this is not related to pfsense but to the actual packege.

Im getting these errors when enabling lldp/cdp on a lag interface

Sep 2 12:34:44 ladvd: interface lagg0_vlan117 is invalid
Sep 2 12:35:14 ladvd: interface lagg0_vlan117 is invalid

The daemon dies and respawns constantly because of this. If I don't select
the Lag interface everything works as expected.

LADVD version 1.0.4.2

Associated revisions

Revision 8332312b (diff)
Added by Chris Buechler about 3 years ago

Add function to return the physical interface(s) for a given parent. related to Ticket #5081

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to ladvd
  • Status changed from New to Confirmed
  • Target version deleted (2.2.5)
  • Affected Version changed from 2.2.4 to All
  • Affected Architecture changed from amd64 to All

#2 Updated by Jim Thompson over 3 years ago

  • Assignee set to Jeremy Porter
  • Target version set to 2.3

I'd like Jeremy to recheck this.

#3 Updated by Chris Buechler over 3 years ago

The issue is in any situation with virtual interfaces (lagg or VLANs), the package should enable ladvd on the parent physical interface, not the VLAN or lagg interface(s). It'll only work properly when configured on physical NICs. There's also some kind of problem in ladvd, that it shouldn't go nuts when it tries to use such a config, but it's an invalid config that causes the problems.

#4 Updated by Kill Bill over 3 years ago

@Chris - you have some good code example to check for bridge/lagg and drill down to physical ones? Couldn't really find anything.

#5 Updated by Chris Buechler over 3 years ago

Kill Bill wrote:

@Chris - you have some good code example to check for bridge/lagg and drill down to physical ones? Couldn't really find anything.

I figured surely there are functions there already, but after looking, not in the direction that's needed in this case for VLANs, bridge or lagg. A find_physical_interfaces() function or similar to pass lagg, VLANs, bridge, etc. and return physical NICs would be helpful for this.

#6 Updated by Kill Bill over 3 years ago

Hmmm, so I'm not blind at least :) Franly, I do not feel like inventing something from scratch since I'm definitely not familar with this area.

#7 Updated by Renato Botelho over 3 years ago

  • Subject changed from LADVD failing on LAG INTERFACE to LADVD failing on LAGG INTERFACE

#8 Updated by Chris Buechler about 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Jeremy Porter to Chris Buechler

working for me with the changes I just pushed

#9 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Resolved

works with the latest 1.2.1 package version. Note you have to upgrade the base system as well as it has a new function that's required.

Also available in: Atom PDF