Project

General

Profile

Bug #5092

firewall_virtual_ip.php - Remove "CARP Settings" link/tab

Added by Jim Pingle almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Very Low
Target version:
Start date:
09/03/2015
Due date:
% Done:

100%

Estimated time:

Description

The HA Settings moved to System > High Avail. Sync several versions ago now, probably safe to nuke the "CARP Settings" legacy shortcut on firewall_virtual_ip.php since it doesn't belong there.

IIRC the intent was to only keep it around for one major version past the change. Removing that means the whole "tab" control could be removed from the page, which would clean it up more.

If it's desirable to keep it should at least be renamed "High Availability Settings".

Associated revisions

Revision 59837fb1 (diff)
Added by Steve Beaver almost 4 years ago

Fixed #5092
Nixed CARP tab

Revision 1ed8d35b (diff)
Added by Steve Beaver almost 4 years ago

Fixed #5092
Removed all tabs/pills as requested

History

#1 Updated by Chris Buechler almost 4 years ago

yeah the intention there was to keep the existing tab since it's referenced in so many places all over the Internet. Its name was kept as is for the same reason, to match a slew of list, forum, and old documentation references.

It's been long enough that it's fine to remove.

#2 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Tab zapped as requested

#3 Updated by Steve Beaver almost 4 years ago

  • % Done changed from 0 to 100

#4 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Jim Pingle to Steve Beaver

The "CARP Settings" tab is gone now it just has one "tab" -- "Virtual IPs". Seems odd to just have one tab. Can that be zapped also?

#5 Updated by Steve Beaver almost 4 years ago

Removed as requested

#6 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

#8 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Resolved

Looks much cleaner now, thanks!

Also available in: Atom PDF