Project

General

Profile

Actions

Bug #5162

closed

Renaming an alias to an existing name is not prevented by input validation

Added by Jim Pingle about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Rules / NAT
Target version:
Start date:
09/18/2015
Due date:
% Done:

50%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

If you create two aliases and rename the second one to the same name as the first, it is allowed by the GUI but obviously undesirable. Creating a new alias with the same name as an existing alias is prevented as expected.

Bug is present on 2.1.x, 2.2.x and still on 2.3.

Actions #1

Updated by Jim Pingle about 6 years ago

  • Status changed from New to Confirmed
Actions #3

Updated by Renato Botelho almost 6 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Pull requests have been merged. Thanks!

Actions #4

Updated by Jim Pingle almost 6 years ago

  • Status changed from Feedback to Confirmed

The problem is still present on master (2.3), but appears to be fixed on 2.2.x.

Actions #5

Updated by Jim Pingle almost 6 years ago

  • % Done changed from 100 to 50
Actions #6

Updated by Phillip Davis almost 6 years ago

I don't have a system setup with 2.3 just yet. I looked at the processing and the new bootstrap code still seems to pass across 'id' like before, and:
$a_aliases = &$config['aliases']['alias'];
looks to have the same structure as previously.
So I expect that the same validation loop from 2.2.* will work in 2.3
Hmmm - what is the trick?

Actions #7

Updated by Jim Pingle almost 6 years ago

  • Status changed from Confirmed to Resolved

I synchronized my VM again and now it worked. Somehow it must not have picked up this change the first try.

Actions

Also available in: Atom PDF