Project

General

Profile

Actions

Bug #527

closed

Captive Portal idle timeout is not functioning

Added by Jim Pingle over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
04/19/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

http://forum.pfsense.org/index.php/topic,24451.0.html

CP's idle timeout isn't working on 2.0, as stated in the thread above. The following error shows up in the system logs:

php: /services_captiveportal.php: The command '/sbin/ipfw -f delete set 1' returned exit code '69', the output was 'ipfw: rule 16777217: setsockopt(IP_FW_DEL): Invalid argument'

Possibly related, the last activity time is shown as before the session start time.

Actions #1

Updated by Ermal Luçi over 11 years ago

The error in the error logs is fixed in newer snapshots.
For idle timeout more input is needed by the OP.

Actions #2

Updated by Abdsalem Chaoui over 11 years ago

Hi Ermal, Ive tested again with fresh install on a different box, I used a snapshot from 20 apr and gitsyncd from that point onwards.

I can reproduce the same symptoms on this new box.

1. CP user logs in
2. I check Status > CP status page (start time column shows correct time logged in)
3. Clicking on the "show last activity" button on the same page reveals the incorrect timestamp for "last activity".

IP address      MAC address      Username      Session start      Last activity
10.0.5.150      00:1d:72:xx:xx:xx       test       04/21/2010 16:38:12      04/21/2010 16:17:08

It appears to me that the "last activity" column is showing the system uptime instead of the users last activity.

The contents of captiveportal.db if that helps

1271864292,2,10.0.5.150,00:1d:72:xx:xx:xx,test,61b7765232ea5429,,,,

Im not sure what other information I can provide to help you pinpoint the error, just let me know and Ill be happy to assist.

Slam

Actions #3

Updated by Abdsalem Chaoui over 11 years ago

Ive upgraded to pfSense-Full-Update-2.0-BETA1-20100421-2213 and the last activity column seems to be showing the correct timestamp now, Ill test further tonight and report back if I come across any problems.

Thank you

Actions #4

Updated by Chris Buechler over 11 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF