Project

General

Profile

Actions

Bug #5342

closed

Cannot change outbound NAT modes when using non-English translation

Added by Phillip Davis almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
10/24/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

Forum: https://forum.pfsense.org/index.php?topic=101276.0

"Save" is not being translated when checking the $_POST value and so is not matching.

Seems to be a bug since 2006 (forever - never worked since translations existed) https://github.com/pfsense/pfsense/commit/82d0dfc4609f27e691e29e8a379fe8f43beff328

Actions #2

Updated by Phillip Davis almost 6 years ago

Note: PR for master currently breaks the behavior in master, because there are other issues with the (non) translation of UI buttons.

Actions #3

Updated by Jim Thompson almost 6 years ago

  • Assignee changed from Phillip Davis to Steve Beaver
Actions #4

Updated by Steve Beaver almost 6 years ago

  • Status changed from New to Feedback
  • Assignee changed from Steve Beaver to Phillip Davis

I see no need to test the value of the $_POST['save'] parameter so have removed the test.

There were a couple of other issues with the page that have also been corrected.

The action buttons have been changed to icons. There was not enough space in the display to sensibly use icons.

Actions #5

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #6

Updated by Phillip Davis almost 6 years ago

2.3-ALPHA (amd64)
built on Mon Oct 26 19:32:58 CDT 2015
FreeBSD 10.2-STABLE

Works

Actions #7

Updated by Phillip Davis almost 6 years ago

2.2.5-DEVELOPMENT (i386)
built on Mon Oct 26 18:12:44 CDT 2015
FreeBSD 10.1-RELEASE-p23

Works

Actions #8

Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

also confirmed on 2.2.5. thanks Phil!

Actions

Also available in: Atom PDF