Project

General

Profile

Actions

Bug #5379

closed

Installer runs out of RAM and fails with < ~600 MB RAM

Added by Chris Buechler almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
Installer
Target version:
Start date:
11/06/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3
Affected Architecture:

Description

If installing to a system with less than somewhere around 600 MB RAM, the installer fails in after_installation_routines.sh because it runs out of memory. The source of the memory usage appears to be unionfs, as its mounts show ~95-99% full, and that would account for nearly 500 MB RAM usage. Seems to indicate something is writing there that shouldn't be.


Files

2015-11-06_18-24-03.png (70.1 KB) 2015-11-06_18-24-03.png Chris Buechler, 11/06/2015 06:28 PM
Actions #1

Updated by Jim Thompson almost 6 years ago

Bump for re-eval.

Actions #2

Updated by Renato Botelho over 5 years ago

  • Status changed from Confirmed to Feedback

I installed it 5 times on a VM with 256Mb of RAM and was unable to reproduce. Probably overcome by events since installer changed since last Nov

Actions #3

Updated by Chris Buechler over 5 years ago

  • Status changed from Feedback to Resolved

through multiple attempts again, this is definitely no longer an issue. No problem with 256 MB RAM in multiple circumstances where subject was true previously.

Actions

Also available in: Atom PDF