Project

General

Profile

Actions

Bug #5389

closed

system_groupmanager.php & system_usermanager.php -- No means to remove assigned privileges

Added by Jim Pingle about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/09/2015
Due date:
% Done:

100%

Estimated time:

Description

On system_groupmanager.php & system_usermanager.php assigned privileges have no "delete" icon. Once a privilege is added to a user there is no way to remove it.

Actions #2

Updated by Steve Beaver about 6 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Fixed by PR 2047

Actions #3

Updated by Jim Pingle about 6 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Jim Pingle to Steve Beaver

Is that merged? This still isn't working

Actions #4

Updated by jeroen van breedam about 6 years ago

its appears to be still 'open' on github

Actions #5

Updated by Steve Beaver about 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Merged and pushed.

Actions #6

Updated by Jim Pingle about 6 years ago

  • Status changed from Feedback to Resolved

Removing individual privileges for users and groups works fine with that as far as I can see. Thanks!

Actions #7

Updated by Jim Pingle almost 6 years ago

  • Status changed from Resolved to Assigned
  • Assignee changed from Jim Pingle to Steve Beaver

Looks like there is one little issue here yet or perhaps it crept in after other changes. On system_usermanager.php you can't delete the first or last privilege in the list on a user. The others can be removed without issue.

The same operation works OK on a group.

Actions #8

Updated by Jim Pingle almost 6 years ago

May just be the first privilege. I had issues deleting the last one but then after deleting some middle ones it worked -- try starting with 5 or so added to a user.

Actions #9

Updated by Steve Beaver almost 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Priv table was incorrectly numbered because privs inherited from a group should not be deletable

Actions #10

Updated by Steve Beaver almost 6 years ago

  • % Done changed from 0 to 100
Actions #11

Updated by Jim Pingle almost 6 years ago

  • Status changed from Feedback to Resolved

Seems to work OK now.

Actions

Also available in: Atom PDF