Project

General

Profile

Bug #5400

diag_ping.php - Following link to pre-fill page results in an incorrect error

Added by Jim Pingle almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/09/2015
Due date:
% Done:

100%

Estimated time:

Description

If you follow a link, such as one from Diag > DNS Lookup, to diag_ping.php similar to this:

diag_ping.php?host=google.com&interface=wan&count=3

The page loads displaying an error that the host couldn't be resolved or didn't respond, which isn't true the ping just hasn't been done yet (since it shouldn't take action until run via POST)

Associated revisions

Revision 7d67222e (diff)
Added by jeroen van breedam almost 4 years ago

fix Bug #5400

interface=wan could be offline/disabled in multi-wan systems.
also, currently no code in diag_ping.php to convert 'wan' => source-ip

Revision ed69a496 (diff)
Added by Jim Pingle almost 4 years ago

For Diag > Ping and Diag > Traceroute, only perform the action on POST, not by following a link/GET. Fixes #5400

History

#2 Updated by Steve Beaver almost 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Fixed by heper:patch-2 PR: 1932 now merged.

#3 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Jim Pingle to Steve Beaver

This shouldn't be taking the action on following the link, it should only be pre-filling the form. Automatically taking an action like that on GET isn't desirable.

#4 Updated by Jim Pingle almost 4 years ago

  • Assignee changed from Steve Beaver to Jim Pingle

I'll take this, looks like there is a similar problem with traceroute, I've got a fix.

#5 Updated by Jim Pingle almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#6 Updated by Jim Pingle almost 4 years ago

  • Status changed from Feedback to Resolved

Looks good here, it's behaving as expected now. No errors on load and it does not take action until the form is submitted.

Also available in: Atom PDF