Project

General

Profile

Bug #5427

Crash reports submitted on 2.3 are empty on the server

Added by Jim Pingle over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
11/12/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

I submitted two crash reports from a 2.3 system, one last night and a test one this morning. GUI on the client claims the report was submitted OK. Server shows the directory with my IP address, but there is nothing in the directory at all.

Associated revisions

Revision f6c1ade2 (diff)
Added by Chris Buechler over 3 years ago

CURLOPT_SAFE_UPLOAD's default changed to false in PHP 5.6. Restore former behavior for crash reporter. Ticket #5427

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee set to Renato Botelho

we need an automated test for this as well.

because it breaks a lot.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Renato Botelho to Chris Buechler

works now.

It's broken once server-side (too many files in directory), and this in 2.3, and the issue with symlinks making some crash reports fail. Far from a lot. Not easily monitored outside the complete failure server-side, will check into monitoring that.

#3 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

Confirmed working here. Updated a VM that had a pending crash dump, submitted and checked the server and it's there.

Also available in: Atom PDF