Project

General

Profile

Bug #5621

dhcp6c running twice with PPP. random interface ID issue at boot time

Added by Martijn Coenen over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP6
Target version:
Start date:
12/10/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

Issue 1: Multiple dhcp6c processes on one interface issue, leading to broken IPv6 connectivity
Issue 2: Issue 2: Random interface identifiers when interfaces connect at boot time

full description:
https://forum.pfsense.org/index.php?topic=101967.msg584693#msg584693

Associated revisions

Revision 0c9b98c0 (diff)
Added by Chris Buechler over 3 years ago

Import David W's patch fixing issues with dhcp6c being launched multiple times in some circumstances. Ticket #5621

History

#1 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.3

This is something David's been working on and has a fix that's been confirmed by a few in this thread.
https://forum.pfsense.org/index.php?topic=101967.60

which he'll be submitting as a pull request soon

#2 Updated by Jim Thompson over 3 years ago

  • Assignee set to Renato Botelho

#3 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

David hasn't been around in a couple weeks. Myself and several people on the forum have tested his change to fix this issue and it works. I went ahead and committed it.

#4 Updated by Chris Buechler over 3 years ago

David submitted a pull request to RELENG_2_2 for this as well, which has been merged.
https://github.com/pfsense/pfsense/pull/2575

#5 Updated by Chris Buechler over 3 years ago

  • Assignee changed from Renato Botelho to Chris Buechler

I've been working with David on this for a while, I'll take it.

#6 Updated by David Wood over 3 years ago

Thanks for the merge to master, Chris. I submitted a pull request for the RELENG_2_2 version of the patch at https://github.com/pfsense/pfsense/pull/2575 and note that you have now merged that, too.

These patches also fix the problem of random interface identifiers on PPPĀ IPv6 interfaces at boot time (issue 2 in https://forum.pfsense.org/index.php?topic=101967.30 ). That issue really ought to have its own redmine bug, as the root cause is an issue in mpd5. It should also be reported as an mpd5 bug.

#7 Updated by Chris Buechler over 3 years ago

  • Subject changed from dhcp6c running twice due to recently merged change to dhcp6c running twice with PPP. random interface ID issue at boot time
  • Description updated (diff)
  • Status changed from Feedback to Resolved

updating this ticket to include both those issues since the commits were done under this ticket number.

This is fixed.

Appreciate all your work, David.

#8 Updated by Martijn Coenen over 3 years ago

Thanks for the fix!

Also available in: Atom PDF