Project

General

Profile

Bug #5703

Update FreeRADIUS to v2.2.9

Added by Paul K almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
FreeRADIUS
Target version:
-
Start date:
12/27/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
All

Description

There is a known issue with FreeRADIUS calculating incorrect MPPE keys when using TLS 1.2. This issue was fixed in v2.2.9. This was not an issue with v2.2.5 since it did not support TLS 1.2.

This is breaking all TLS based EAP types when using wpa_supplicant>=v2.4. This includes Android 6.0 and iOS 9 beta, before Apple reverted to TLS 1.0.

Additional Info:

https://rhn.redhat.com/errata/RHBA-2015-1829.html
https://code.google.com/p/android/issues/detail?id=188867#c29

History

#1 Updated by Chris Buechler almost 4 years ago

  • Tracker changed from Todo to Bug
  • Status changed from New to Duplicate

duplicate of #5318

#2 Updated by Paul K almost 4 years ago

Sorry for the dupe, I swear I searched, I thought searching under pfSense projects also includes packages, but turns out that is not the case :)

Also available in: Atom PDF