Project

General

Profile

Bug #5318

Upgrade FreeRadius to 2.2.9

Added by Cristian Menghi about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
FreeRADIUS
Target version:
Start date:
10/18/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
All

Description

Hi, This upgrade is required for the bugs with TLS 1.2, this affect the use of Android 6 and iOS 9 devices, the explanation is in #29 of this ticket
https://code.google.com/p/android/issues/detail?id=188867

Thanks.

History

#1 Updated by Jim Pingle about 4 years ago

  • Assignee changed from Chris Buechler to Renato Botelho

Renato said it had a problem building due to OpenSSL errors. He wanted it assigned to him since it'll take some research/work.

#2 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Confirmed
  • Priority changed from Urgent to Normal
  • Affected Version deleted (2.2.4)

#3 Updated by Cullen Trey about 4 years ago

hi,

Windows 10 has adapted this "problem" also...

https://support.microsoft.com/en-us/kb/3121002

Would be nice to have it working again.

#4 Updated by Cristian Menghi almost 4 years ago

Jim P wrote:

Renato said it had a problem building due to OpenSSL errors. He wanted it assigned to him since it'll take some research/work.

Hi, any update or something to fix this issue ? or i need to wait to 2.3 release ? Thanks in advance!

#5 Updated by Marcus B almost 4 years ago

If there are problems compiling v2.2.9....
For the short term, could we not just change the makefile of the currently used version (v2.2.6) to not report TLS v1.2?

CONFIG_TLSV12=n

#6 Updated by Cristian Menghi almost 4 years ago

Hi, i'm think is not a fix, because TLSv1.2 is required by android 6 & iOS 9.2

Thanks.

#7 Updated by Jim Pingle almost 4 years ago

2.3 is still on FreeRADIUS 2.2.8 as well because it is tracking the FreeBSD quarterly ports tree. That will be cycled out tomorrow, merged next week sometime, so it should get picked up for 2.3 at least by then. 2.2.x is still up in the air since generating PBIs for it is a mess currently. Doesn't matter if it's an upgrade or regenerating the existing version, it's a mess either way.

#8 Updated by Jim Pingle almost 4 years ago

The FreeRADIUS package on 2.3 is working and is using FreeRADIUS 2.2.9 for those that need the fix and don't want to wait for this issue to be resolved.

#9 Updated by Tommaso Carrara almost 4 years ago

Hi there,

I have pfsense 2.2.6 running, but I can' t see any freeradius 2.2.9 available. The latest, which is the one I have, is 2.2.6 as per the output below.

[2.2.6-RELEASE][]/root: radiusd -v
radiusd: FreeRADIUS Version 2.2.6, for host i386-portbld-freebsd10.1, built on Jan 28 2015 at 18:54:41
Copyright (C) 1999-2013 The FreeRADIUS server project and contributors.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
You may redistribute copies of FreeRADIUS under the terms of the
GNU General Public License.
For more information about these matters, see the file named COPYRIGHT.

Did you mean 2.2.9 is available on freeradius 2.3 as in : it' s available on that specific release of pfsense and not on others ?
If so, would it be safe to update il manually via cli using that package or this would break the current package ?

TA

#10 Updated by Jim Pingle almost 4 years ago

  • Status changed from Confirmed to Feedback

To get FreeRADIUS 2.2.9 you have to be running pfSense 2.3, which is still beta (but quite stable)

#11 Updated by Tommaso Carrara almost 4 years ago

Oh, sorry I read 2.2.3 for some reasons, and that's why I didn't get it initially.
Thanks

#12 Updated by Tommaso Carrara almost 4 years ago

Do you guys think that using pkg install freeradius ( 2.2.9 available ) and make use of that binary would mess things up ?

#13 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 2.3

Also available in: Atom PDF