Project

General

Profile

Actions

Bug #5947

closed

After updating to latest 2.3, snort's SID management files are missing

Added by George Phillips over 5 years ago. Updated over 5 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/03/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:
All

Description

The file disablesid-sample.conf file reverts to a default file.

Actions #1

Updated by George Phillips over 5 years ago

George Phillips wrote:

The file disablesid-sample.conf file reverts to a default file.

This happened while updating from a previous 2.3 version to the latest on 2016-03-03.

Actions #2

Updated by Bill Meeks over 5 years ago

George:

Can you provide some clarification on the issue you are reporting? Did you have customized SID management changes saved in the disablesid-sample.conf file? If so, then that file does always get overwritten during an upgrade or package reinstall by design. The three sample files are meant to be just samples. Maybe the GUI is a bit confusing on that point since it shows the three files and lets the user edit them. The idea is for the user to either import his own files with different names, or save an edited version of the sample files with a new name.

If you mean instead that you had custom SID management files with names different from the sample ones, and those files got deleted, then that would be an unexpected bug (unless you run a NanoBSD install).

Can you let me know which scenario fits your reported issue?

Thanks,

Bill

Actions #3

Updated by George Phillips over 5 years ago

Bill Meeks wrote:

George:

Can you provide some clarification on the issue you are reporting? Did you have customized SID management changes saved in the disablesid-sample.conf file? If so, then that file does always get overwritten during an upgrade or package reinstall by design. The three sample files are meant to be just samples. Maybe the GUI is a bit confusing on that point since it shows the three files and lets the user edit them. The idea is for the user to either import his own files with different names, or save an edited version of the sample files with a new name.

If you mean instead that you had custom SID management files with names different from the sample ones, and those files got deleted, then that would be an unexpected bug (unless you run a NanoBSD install).

Can you let me know which scenario fits your reported issue?

Thanks,

Bill

Ahh! I was just using the sample files, and adding my SID lists to them. Didn't know they got overwritten each time. My bad. Thanks!

Actions #4

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.3)
Actions

Also available in: Atom PDF