Project

General

Profile

Bug #6039

Using DNS Lookup to create IPv6 alias

Added by Michel Nolf over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Diagnostics
Target version:
Start date:
03/29/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

When creating an alias using the DNS Lookup (Diagnostics menu, the IPV6 address is created using /32 instead of /128

Associated revisions

Revision 97f42a05 (diff)
Added by Renato Botelho over 3 years ago

Use correct subnet mask for IPv6. Fixes #6039

History

#1 Updated by Jim Thompson over 3 years ago

  • Assignee set to Steve Beaver

#2 Updated by Jim Thompson over 3 years ago

  • Target version set to 2.3

#3 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved
  • Affected Version changed from 2.3 to All
  • Affected Architecture deleted (amd64)

works. Not sure how you'd end up with an IPv6 IP there currently given drill is doing an A record lookup, had to manually change the source to make it do an AAAA to replicate. There's a feature ticket open to add IPv6 support there.

#5 Updated by Michel Nolf over 3 years ago

Not sure if it is useful, but here is how I made it.
I am runnind a bind with ipv6 and ipv4 entries. In the dns lookup, I enter the name of a dual stack server. Pfsense returns the ipv4 and ipv6 as it should be. Than I just click on the ┬┤add alias' button.

Btw, I checked this morning and I confirm that the issue is solved.

Thankx

Also available in: Atom PDF