Project

General

Profile

Bug #6054

Unbound first run errors

Added by Dmitriy K about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
DNS Resolver
Target version:
Start date:
04/01/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Apr 1 08:32:51 unbound 42511:0 error: Error for server-cert-file: /var/unbound/unbound_server.pem
Apr 1 08:32:51 unbound 42511:0 error: Error in SSL_CTX use_certificate_chain_file crypto error:02001002:system library:fopen:No such file or directory
Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:20074002:BIO routines:FILE_CTRL:system lib
Apr 1 08:32:51 unbound 42511:0 error: and additionally crypto error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib
Apr 1 08:32:51 unbound 42511:0 fatal error: could not set up remote-control

Got it on the very first boot after installation (x64). Nothing is configured yet.

History

#1 Updated by Renato Botelho about 3 years ago

Was it a fresh install or upgrade? I did a fresh install here and unbound is up after boot, with no error messages.

#2 Updated by Dmitriy K about 3 years ago

Yeah, it was a fresh installation.

#3 Updated by Jim Thompson about 3 years ago

  • Assignee set to Renato Botelho

#4 Updated by Dmitriy K about 3 years ago

Just done yet another run. Here are steps to reproduce:
1. Do fresh install.
2. Check "Use RAM disks".
3. Reboot.
4. See logs.

Sorry for previously incorrect information.

#5 Updated by Renato Botelho about 3 years ago

  • Status changed from New to Feedback

Did you set any specific size for /var memory disk? I couldn't reproduce the problem following the steps you mentioned. After enable MFS and reboot it runs as expected:

[2.3-RC][admin@pfSense.localdomain]/root: ps auxwww | grep unbound
unbound 52327  0.0  1.1  34492 11000  -  Is    7:32PM 0:00.06 /usr/local/sbin/unbound -c /var/unbound/unbound.conf
[2.3-RC][admin@pfSense.localdomain]/root: find /var/unbound/
/var/unbound/
/var/unbound/host_entries.conf
/var/unbound/dhcpleases_entries.conf
/var/unbound/root.key
/var/unbound/remotecontrol.conf
/var/unbound/unbound_server.key
/var/unbound/unbound_control.key
/var/unbound/domainoverrides.conf
/var/unbound/access_lists.conf
/var/unbound/unbound.conf
/var/unbound/unbound_server.pem
/var/unbound/unbound_control.pem
[2.3-RC][admin@pfSense.localdomain]/root: df -h
Filesystem                     Size    Used   Avail Capacity  Mounted on
/dev/ufsid/570295f9d51704b2    2.9G    549M    2.1G    20%    /
devfs                          1.0K    1.0K      0B   100%    /dev
/dev/md0                        38M     76K     35M     0%    /tmp
/dev/md1                        58M     18M     35M    33%    /var
devfs                          1.0K    1.0K      0B   100%    /var/dhcpd/dev

#6 Updated by Dmitriy K about 3 years ago

I used default values for RAM disks on a 512MB RAM VM: 40MB for /tmp and 60MB for /var. HDD size is 5GB.

#7 Updated by Renato Botelho about 3 years ago

Can you reproduce it with most recent snapshot? I couldn't

#8 Updated by Dmitriy K about 3 years ago

I've downloaded OLD build (201604*03*-1424) snapshot: Reproducing.

Newer build (201604*04*-1709): Not reproducing.

So, this bug is fixed now.

#9 Updated by Renato Botelho about 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF