Project

General

Profile

Bug #6055

Menu items may remain from packages no longer installed

Added by Pim Pish over 3 years ago. Updated about 3 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Package System
Target version:
-
Start date:
04/01/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

I just upgraded to 2.3 RC as described here: https://forum.pfsense.org/index.php?topic=109104.0

Under Services there is OLSRD visible, even though not being installed. The package I once had installed. It was removed in the previous version of my pfsense installation (i.e. 2.2.6). Package was definitely not installed during upgrade.

When I actually hit OLSR in the menu, I get this error:

Package path /usr/local/pkg//olsrd.xml not found.
Try reinstalling the package.

OLSRD cannot be installed, because it isn't available any longer.
I did not do a gitsync actually, but also couldn't find an related bugreport.

History

#1 Updated by Chris Buechler over 3 years ago

  • Subject changed from OLSRD still in WebGUI after upgrade to 2.3 RC to Menu items may remain from packages no longer installed
  • Status changed from New to Confirmed
  • Affected Version changed from 2.3 to All

That can happen with any package in that circumstance (and has always been the case).

#2 Updated by Adrien Carlyle about 3 years ago

Is there any way to manually correct this?

#3 Updated by Chris Buechler about 3 years ago

Adrien Carlyle wrote:

Is there any way to manually correct this?

Edit the <menu> tag(s) out of the config manually.

Also available in: Atom PDF