Project

General

Profile

Bug #6089

PHP warning when saving client-specific override with no server selected.

Added by Phillip Davis about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
04/07/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Add an OpenVPN Client Specific Override, and do not select any server (so it should apply to all servers).
A crash report is generated like:
PHP Errors:
PHP Stack trace:
PHP 1. {main}() /usr/local/www/vpn_openvpn_csc.php:0
PHP 2. implode() /usr/local/www/vpn_openvpn_csc.php:243

Interestingly, the Client Specific Override is saved, so the problem with implode() at line 243 is not stopping further PHP execution.

Reported in forum https://forum.pfsense.org/index.php?topic=109431.msg0

History

#2 Updated by Chris Buechler about 3 years ago

  • Status changed from New to Feedback

merged, thanks Phil

#3 Updated by Phillip Davis about 3 years ago

It works for me, but some independent person should test it and then mark this resolved.

#4 Updated by Chris Palmer about 3 years ago

Works for me as well.

#5 Updated by Chris Palmer about 3 years ago

But when I deleted the override I got this-

Crash report details:

PHP Errors:
[07-Apr-2016 19:59:19 America/Vancouver] PHP Stack trace:
[07-Apr-2016 19:59:19 America/Vancouver] PHP 1. {main}() /usr/local/www/vpn_openvpn_csc.php:0
[07-Apr-2016 19:59:19 America/Vancouver] PHP 2. implode() /usr/local/www/vpn_openvpn_csc.php:243

Filename: /var/crash/minfree

#6 Updated by Phillip Davis about 3 years ago

I tried to reproduce that, but no success.
Are you sure that you have the new code on your system? Because the implode() code is no longer at line 243.

#7 Updated by Chris Palmer about 3 years ago

Ah- Hadn't synced that particular box... Your right.

Ill gitsync and go again.

#8 Updated by Chris Palmer about 3 years ago

Synced and no errors this time.

#9 Updated by Phillip Davis about 3 years ago

Good to hear.

#10 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Resolved

Also could replicate before and not after. Fixed, thanks!

Also available in: Atom PDF