Project

General

Profile

Bug #6185

pfsense 2.3 w/luajit breaks on 586-class CPUs

Added by Kevin Bowling over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
04/17/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
i386

Description

nginx is built with OPTIONS LUA, so the appliance wont start on 586-class CPUs starting with pfSense 2.3. These CPUs lack the CMOV instruction.

My router is probably a bit fringe, but similar 586 are common in Soekris devices that still work for typical consumer internet speeds.

A suggestion, if this is deemed worthy of even "fixing", would be to disable the luajit CMOV and SSE instruction with a ports patch on the i386 build. https://github.com/LuaDist/luajit/blob/master/CMakeLists.txt#L47 defines some things that will do that easy, but ports uses the gmake build which would need to be patched.

Associated revisions

Revision bdd05750 (diff)
Added by Chris Buechler over 2 years ago

Remove lua from nginx. Ticket #6185

Revision 3b9caf69 (diff)
Added by Chris Buechler over 2 years ago

Remove lua from nginx. Ticket #6185

Revision b3908dd7 (diff)
Added by Chris Buechler over 2 years ago

Keep this on master for 2.4, keep for RELENG_2_3 only. Revert "Remove lua from nginx. Ticket #6185"

This reverts commit bdd05750a76f44306333da87380b78fbd8d5bb16.

History

#1 Updated by Chris Buechler over 2 years ago

  • Status changed from New to Not a Bug
  • Affected Version deleted (2.3)

not supported hardware. The Soekris 5501 and newer have CMOV (I think even the 4801 does). Talking about ~20 year old CPUs in everything but embedded, and over 10 years old in embedded. Our stated minimum CPU requirement has been 500 MHz for several years.

#2 Updated by Jim Thompson over 2 years ago

  • Status changed from Not a Bug to Confirmed

#3 Updated by Jim Thompson over 2 years ago

  • Assignee set to Renato Botelho

#4 Updated by Jim Thompson over 2 years ago

  • Target version set to 2.3.1
  • Affected Version set to 2.3

#5 Updated by Jim Thompson over 2 years ago

Chris Buechler wrote:

not supported hardware. The Soekris 5501 and newer have CMOV (I think even the 4801 does). Talking about ~20 year old CPUs in everything but embedded, and over 10 years old in embedded. Our stated minimum CPU requirement has been 500 MHz for several years.

I think we should fix this, either the way Kevin recommends, or taking LUA out of nginx for 2.3

#6 Updated by Chris Buechler over 2 years ago

  • Status changed from Confirmed to Feedback

Removed lua from nginx, will be in next 2.3.1 snapshot run. Give it a shot and let us know, Kevin. I'm not going to go hunting down hardware that old :)

#7 Updated by Kevin Bowling over 2 years ago

Chris Buechler wrote:

Removed lua from nginx, will be in next 2.3.1 snapshot run. Give it a shot and let us know, Kevin. I'm not going to go hunting down hardware that old :)

I'm not sure if the current snapshots are broken. I got an error message saying it was corrupt when using the web UI manual upload. https://snapshots.pfsense.org/logs/pfSense_RELENG_2_3/i386/build.log says "Sat Apr 23 09:25:11 CDT 2016 -|- Something went wrong, check errors!"

#8 Updated by Chris Buechler over 2 years ago

Something broke cryptostats building, seems like maybe the ipcomp patch. Trying now with that reverted.

In the mean time Kevin, just go back to a snapshot from the 22nd.

#9 Updated by Chris Buechler over 2 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF