Project

General

Profile

Feature #620

No privilege choice to allow access to Dashboard

Added by Maxim Hansen almost 9 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
User manager
Target version:
Start date:
05/27/2010
Due date:
% Done:

0%

Estimated time:

Description

Scenario

You want a group of users (or a single one for that matter) to be able to log into pfSense and just have access to the Dashboard that you composed, in order for them to be able to assess the network status (Interfaces, Gateways, Traffic Graphs, System Information, etc..)

Problem:

There is no 'WebCfg - Status: Dashboard page' option in "System: User/Group manager: Add privileges -> System Privileges" list.

Associated revisions

Revision 72f7c837 (diff)
Added by Jim Pingle almost 8 years ago

Add Dashboard privilege which is a collection of all required pages for the dashboard. Partial fix for ticket #620 - may do something more for 2.1

Revision 5457129f (diff)
Added by Jim Pingle almost 8 years ago

Add Dashboard privilege which is a collection of all required pages for the dashboard. Partial fix for ticket #620 - may do something more for 2.1

History

#1 Updated by Jim Pingle almost 9 years ago

That page identifies itself as "System: Login / Logout page" - not 100% sure why it can't be Dashboard, Index, or "Main Page" but any of those would apply.

In the meantime you can try using that privilege to see if it has the desired effect.

#2 Updated by Maxim Hansen almost 9 years ago

Ah, I see. Not quite intuitive, but that solved part of the problem. Now the issue is to display the dashboard correctly.
As you can see below, some information isn't displayed. I tried assigning the following privileges to solve the issue, but it didn't have any effect.

Name Description
WebCfg - System: Login / Logout page Allow access to the 'System: Login / Logout' page.
WebCfg - Status: CPU load page Allow access to the 'Status: CPU load' page.
WebCfg - Status: Traffic Graph page Allow access to the 'Status: Traffic Graph' page.

#3 Updated by Maxim Hansen almost 9 years ago

I have now tried adding all the privileges that seem remotely related to the sections that aren't working on the Dashboard, with no luck. Unless I add 'WebCfg - All pages', the result is the same as above.

Currently the following privileges are applied to the group with no positive results:
Name Description
WebCfg - System: Login / Logout page Allow access to the 'System: Login / Logout' page.
WebCfg - Status: CPU load page Allow access to the 'Status: CPU load' page.
WebCfg - Status: Traffic Graph page Allow access to the 'Status: Traffic Graph' page.
WebCfg - Diagnostics: System Activity Allows access to the 'Diagnostics: System Activity' page
WebCfg - Diagnostics: CPU Utilization page Allow access to the 'Diagnostics: CPU Utilization' page.
WebCfg - Required for javascript page Allow access to the 'Required for javascript' page.
WebCfg - Status: RRD Graphs page Allow access to the 'Status: RRD Graphs' page.

So is this a bug, or am I still missing something? =)

#4 Updated by Ermal Luçi about 8 years ago

Although that is not easy on 2.0
You need to add also

Allow access to the 'XMLRPC Interface Stats' page.

#5 Updated by Ermal Luçi almost 8 years ago

  • Target version changed from 2.0 to 2.1

Presently there is no proper way to do it.
The solution is envolved and it will wait 2.1

#6 Updated by Jim Pingle almost 8 years ago

This should be worked around for now on 2.0/2.1 but if there is a more elegant long-term solution for 2.1 that would be nice to have.

#7 Updated by Jim Pingle about 7 years ago

  • Target version changed from 2.1 to 2.2

#8 Updated by Jim Pingle almost 5 years ago

  • Target version changed from 2.2 to 2.3

The current permission seems to be fine for most everyone. If we need to improve upon this, it can wait until after 2.2

#9 Updated by Jim Thompson over 3 years ago

  • Tracker changed from Bug to Feature
  • Assignee set to Renato Botelho

#10 Updated by Jim Pingle over 3 years ago

We haven't had any complaints about this in a while, the current privilege for the Dashboard seems to be working for everyone. May not be worth any extra effort here, we could just close this out.

#11 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Resolved

As mentioned by Pingle, no complaints in a while, current privileges seems to be working

Also available in: Atom PDF