Project

General

Profile

Bug #631

Error when trying to change lan Ip address.

Added by Oscar Francia almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
05/31/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Last nanobsd 1G image: pfSense-2.0-BETA1-1g-20100531-0018-nanobsd.img.gz
Skipping wizard and click on "Interfaces" > "LAN"
error: Fatal error: Cannot redeclare flowtable_configure() (previously declared in /etc/inc/filter.inc:61) in /etc/inc/filter.inc on line 87

Associated revisions

Revision f81cfcc9 (diff)
Added by Jim Pingle almost 9 years ago

Use require_once instead of require, in case these files have been loaded previously. Fixes #631

History

#1 Updated by Erik Fonnesbeck almost 9 years ago

I don't see anything wrong with the function or anything around it. Maybe something on the interfaces.php page is including filter.inc twice.

#2 Updated by Jim Pingle almost 9 years ago

I can't reproduce this using a NanoBSD image from Thu Jun 3 00:43:26 EDT 2010. Can you try a newer snapshot?

#3 Updated by Erik Fonnesbeck almost 9 years ago

When I looked at it yesterday, I didn't see anything in the history that looked like it could be the cause. Could it have anything to do with that interfaces.php uses require rather than require_once? flowtable_configure is simply the first function defined in filter.inc, so it would be the first for it to give an error on.

#4 Updated by Jim Pingle almost 9 years ago

It's possible, but if it were that big of an issue it should be happening more often, and others should be able to reproduce it. It wouldn't hurt to change those to require_once anyhow. I'll commit that just in case.

#5 Updated by Jim Pingle almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#6 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF