Project

General

Profile

Bug #6396

504 gateway time out nginx

Added by Alex Vergilis almost 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
05/23/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

On 2.3.1 after a bit of uptime, the web interface becomes inaccessible with the following message on a Netgate APU FW-7541 upgraded from 2.2.6 to 2.3.1:

504 Gateway Time-out nginx

The following is in the system log:

nginx: 2016/05/23 00:00:00 [error] 39364#0: *1 upstream timed out (60: Operation timed out) while reading response header from upstream, client: 192.168.1.2, server: , request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket", host: "fw.example.com:8443" 

Running option 16 from the console temporarily addresses the problem until it happens again in about an hour.

BadGatewayNginx.png (30.3 KB) BadGatewayNginx.png Screen copy Lepiment ASBL, 10/20/2017 05:06 AM
SSH.png (8.16 KB) SSH.png SSH remote console Lepiment ASBL, 10/20/2017 05:18 AM

History

#1 Updated by Chris Buechler almost 3 years ago

  • Status changed from New to Feedback
  • Affected Version changed from 2.3.1 to 2.3.x

there are limitless possible reasons for this to happen, just means php-fpm is hung up doing something. One I've heard from a couple people that doesn't have a bug ticket yet is the IPsec dashboard widget. That on the one in question? If so does the problem go away minus that widget?

#2 Updated by Alex Vergilis almost 3 years ago

Removing the IPsec widget appears to have prevented the eventual failure. This sounds like a different issue. Irrespective of what component may run, the firewall service should be up and available. If it isn't working, it should be restarted and failure logged.

Are you able to duplicate this? Would you like access to my system to assist with debugging?

Would you like me to create a ticket for for the Ipsec widget?

#3 Updated by Chris Buechler almost 3 years ago

  • Status changed from Feedback to Duplicate

this is a duplicate of #6318 then. Yes if it's that easy to replicate, please email me so we can arrange access. thanks!

#4 Updated by Chris Buechler almost 3 years ago

  • Status changed from Duplicate to Resolved
  • Target version changed from 2.3.2 to 2.3.1_1
  • Affected Version changed from 2.3.x to All

The change I made on #6318 resolves subject issue generally. I'll un-mark this as a duplicate for tracking purposes since subject is a general problem that was resolved by that change, and #6318 will stay open to address the root cause of this particular instance of subject problem.

#5 Updated by Alex Vergilis almost 3 years ago

Chris,

That same system is now displaying the following message, and the UI is down:

502 Bad Gateway

nginx

#6 Updated by Chris Buechler almost 3 years ago

the 502 is something different and unrelated, cause wasn't apparent. Keeping an eye on it

#7 Updated by Alex Vergilis almost 3 years ago

502 Bad Gateway happened again.

#8 Updated by Lepiment ASBL over 1 year ago

502 Bad Gateway happened again.

#9 Updated by Lepiment ASBL over 1 year ago

And SSH console freezes after admin login. Firewall works, people can access Internet, but reboot is needed to recover access to admin interfaces (web or ssh).

Also available in: Atom PDF