Project

General

Profile

Actions

Bug #6477

closed

Sample bounds can jump around for custom timer periods on Status > Monitoring

Added by Jared Dillard almost 6 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Jared Dillard
Category:
RRD Graphs
Target version:
Start date:
06/09/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.x
Affected Architecture:

Description

Due to the way rrd_fetch tries to find the best fit for a time period, the custom time period can move around slightly from the desired start/end time, which can lead to missing sample points at the beginning or end.

Some further discussion on the issue can be found here: https://github.com/pfsense/FreeBSD-ports/pull/145

Actions #1

Updated by Chris Buechler almost 6 years ago

  • Target version changed from 2.3.2 to 2.4.0
  • Affected Version changed from 2.3.1 to 2.3.x
Actions #2

Updated by Renato Botelho over 4 years ago

  • Target version changed from 2.4.0 to 2.4.1
Actions #3

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.1 to 2.4.2
Actions #4

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.2 to 2.4.3
Actions #5

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.3 to 2.4.4
Actions #6

Updated by Anonymous almost 4 years ago

On 2.4.4.a.20180707.0234 the does not appear to be an issue when viewing the Status > Monitoring graph at 1 hour time period, with resolution set to 1 minute. The first and last minute both appear to be represented accurately.

Actions #7

Updated by Jim Pingle almost 4 years ago

  • Status changed from New to Feedback
Actions #8

Updated by Anonymous almost 4 years ago

On 2.4.4.a.20180720.1418, cannot reproduce. At one hour time period, with one minute resolution, the graph looks fine.

Actions #9

Updated by Anonymous almost 4 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF