Project

General

Profile

Bug #6529

dhcp6c fails to start with track6 on a bridge interface

Added by Kai Groner almost 4 years ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv6)
Target version:
-
Start date:
06/24/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

I noticed today that IPv6 wasn't working, and found this in the dhcpd log.

Jun 18 03:49:31 blat dhclient: PREINIT
Jun 18 03:49:31 blat dhclient[5457]: DHCPREQUEST on em0 to 255.255.255.255 port 67
Jun 18 03:49:31 blat dhclient[5457]: DHCPACK from 96.120.18.197
Jun 18 03:49:31 blat dhclient: REBOOT
Jun 18 03:49:31 blat dhclient: Starting add_new_address()
Jun 18 03:49:31 blat dhclient: ifconfig em0 inet 73.251.18.XYZ netmask 255.255.254.0 broadcast 255.255.255.255 
Jun 18 03:49:31 blat dhclient: New IP Address (em0): 73.251.18.XYZ
Jun 18 03:49:31 blat dhclient: New Subnet Mask (em0): 255.255.254.0
Jun 18 03:49:31 blat dhclient: New Broadcast Address (em0): 255.255.255.255
Jun 18 03:49:31 blat dhclient: New Routers (em0): 73.251.18.1
Jun 18 03:49:31 blat dhclient: Adding new routes to interface: em0
Jun 18 03:49:31 blat dhclient: /sbin/route add default 73.251.18.1
Jun 18 03:49:31 blat dhclient: Creating resolv.conf
Jun 18 03:49:31 blat dhclient[5457]: bound to 73.251.18.XYZ -- renewal in 90508 seconds.
Jun 18 03:49:35 blat dhcp6c[14649]: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory
Jun 18 03:49:35 blat dhcp6c[14649]: failed initialize control message authentication
Jun 18 03:49:35 blat dhcp6c[14649]: skip opening control port
Jun 18 03:49:35 blat dhcp6c[14649]: /var/etc/dhcp6c_wan.conf:14 invalid interface (bridge0): Device not configured
Jun 18 03:49:35 blat dhcp6c[14649]: failed to parse configuration file

History

#1 Updated by Chris Buechler almost 4 years ago

  • Subject changed from dhcp6c fails to start when lan interface is not configured yet to dhcp6c fails to start with track6 on a bridge interface
  • Category changed from DHCP (IPv6) to Interfaces
  • Status changed from New to Confirmed
  • Affected Version changed from 2.3.1 to All
  • Affected Architecture added
  • Affected Architecture deleted (amd64)

#2 Updated by Mathew Keith over 2 years ago

I am adding a sighting. My logs are as follows:
Jul 12 06:23:21 pfSense dhcp6c[17300]: /var/etc/dhcp6c_wan.conf:13 invalid interface (bridge0): Device not configured
Jul 12 06:23:21 pfSense dhcp6c[17300]: called
Jul 12 06:23:21 pfSense dhcp6c[17300]: failed to parse configuration file
Jul 14 05:26:11 pfSense dhcp6c[15931]: extracted an existing DUID from /var/db/dhcp6c_duid: 00:01:00:01:1e:bf:73:b6:00:08:a2:0a:77:e9
Jul 14 05:26:11 pfSense dhcp6c[15931]: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory
Jul 14 05:26:11 pfSense dhcp6c[15931]: failed initialize control message authentication

I am currently running:
2.4.0-BETA (amd64)
built on Thu Jul 13 21:03:26 CDT 2017
FreeBSD 11.0-RELEASE-p11

After a couple of days I lose ipv6 until I release and renew the wan interface.

#3 Updated by Sven Kirschbaum almost 2 years ago

still present on 2.4.3-RELEASE-p1.

after a restart dhcp6c starts before the bridge is configured and fails. Ipv6 wont work until the interface is manually reconfigured or dhcp renewed.

May 17 19:33:56 dhcp6c 13936 /var/etc/dhcp6c_wan.conf:18 invalid interface (bridge0): Device not configured
May 17 19:33:56 dhcp6c 13936 failed to parse configuration file

#4 Updated by Jim Pingle 4 months ago

  • Category changed from Interfaces to DHCP (IPv6)
  • Status changed from Confirmed to Duplicate

Duplicate of #3965

Also available in: Atom PDF