Project

General

Profile

Actions

Bug #6629

closed

Can't update to "update" update (e.g. 2.3.1_5)

Added by Jonathon Reinhart over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Upgrade
Target version:
-
Start date:
07/19/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.1
Affected Architecture:

Description

It appears that there is an update available, but when I try to install it, pfSense says it's up-to-date.

I just installed a VM from pfSense-CE-2.3.1-RELEASE-amd64.iso.gz, and currently, my dashboard says:

Version    2.3.1-RELEASE (amd64) 
built on Tue May 17 18:46:53 CDT 2016 
FreeBSD 10.3-RELEASE-p3 

Version 2.3.1_5 is available.

When I click the little cloud-download icon, I am taken to the page /pkg_mgr_install.php?id=firmware where I see

Current Base System: 2.3.1
Latest Base System: 2.3.1
Status: Up to date.

Sorry for the awful title, I'm not sure how to word it any differently. Also, sorry if this is a duplicate, it was incredibly hard to search for.

Actions #1

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Feedback

not replicable. Those two pages use the same function to obtain their data, so no apparent means for one to show an update that the other doesn't. Though I recall hearing same from someone else at some point, IIRC just refreshing the page a couple times made it show. Go to Diag>Command and in the PHP Execute box, put in:

require_once("pkg-utils.inc");
var_dump(get_system_pkg_version());

and hit Execute, what does that return?

Actions #2

Updated by Steve Beaver over 5 years ago

I observed the same thing about a week ago. Performing an update from the console resolved the issue.

Actions #3

Updated by Jonathon Reinhart over 5 years ago

Chris Buechler wrote:

not replicable. Those two pages use the same function to obtain their data, so no apparent means for one to show an update that the other doesn't. Though I recall hearing same from someone else at some point, IIRC just refreshing the page a couple times made it show. Go to Diag>Command and in the PHP Execute box, put in:

[...]

and hit Execute, what does that return?


array(3) {
  'pkg_name' =>
  string(7) "pfSense" 
  'version' =>
  string(7) "2.3.1_5" 
  'installed_version' =>
  string(5) "2.3.1" 
}
Actions #4

Updated by Chris Buechler over 5 years ago

which is correct, guessing it's no longer showing as described? As that output would give you 2.3.1_5 as an update available.

Actions #5

Updated by Jim Pingle over 4 years ago

  • Status changed from Feedback to Resolved

Lots of upgrade issues have been fixed since this report. Most anything left is either cosmetic, caused by network connectivity problems, or something wrong with the local installation that isn't the fault of the upgrade process.

Actions

Also available in: Atom PDF