Project

General

Profile

Bug #6739

OpenVPN compression settings in the GUI are no longer translated into the correct running options.

Added by Steve Wheeler 8 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
08/22/2016
Due date:
% Done:

100%

Affected version:
2.3.2
Affected Architecture:
All

Description

The OpenVPN compression settings available in the GUI: "No preference", "Disabled", "Enabled with adaptive compression" and "Enabled without adaptive compression", do not produce the expected behavior in the running server.

They appear in the .conf file as, respectively:
No setting
comp-lzo no
comp-lzo adaptive
comp-lzo yes

Some or all of those settings need updating to work with the current server version.

Associated revisions

Revision 946a87ec
Added by Jim Pingle 8 months ago

Add a selection for OpenVPN to have no compression preference + comp-noadapt, which is necessary in some client edge cases. Fixes #6739

Revision 9446ee68
Added by Jim Pingle 8 months ago

Add a selection for OpenVPN to have no compression preference + comp-noadapt, which is necessary in some client edge cases. Fixes #6739

History

#1 Updated by Jim Pingle 8 months ago

  • Description updated (diff)
  • Category set to OpenVPN
  • Assignee set to Jim Pingle
  • Target version set to 2.4.0

Specifically it needs to make use of "comp-noadapt" to forcefully disable adaptive compression at least in the "No Preference" case, but the wording needs some thought.

#2 Updated by Jim Pingle 8 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved

This seems to be OK now. The comp-noadapt change was confirmed to work on an affected system (remote client had no LZO compiled in)

#4 Updated by Jim Pingle 3 months ago

  • Target version changed from 2.4.0 to 2.3.3

Also available in: Atom PDF