Project

General

Profile

Actions

Bug #6739

closed

OpenVPN compression settings in the GUI are no longer translated into the correct running options.

Added by Steve Wheeler about 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
08/22/2016
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.2
Affected Architecture:
All

Description

The OpenVPN compression settings available in the GUI: "No preference", "Disabled", "Enabled with adaptive compression" and "Enabled without adaptive compression", do not produce the expected behavior in the running server.

They appear in the .conf file as, respectively:
No setting
comp-lzo no
comp-lzo adaptive
comp-lzo yes

Some or all of those settings need updating to work with the current server version.

Actions #1

Updated by Jim Pingle about 5 years ago

  • Description updated (diff)
  • Category set to OpenVPN
  • Assignee set to Jim Pingle
  • Target version set to 2.4.0

Specifically it needs to make use of "comp-noadapt" to forcefully disable adaptive compression at least in the "No Preference" case, but the wording needs some thought.

Actions #2

Updated by Jim Pingle about 5 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by Jim Pingle almost 5 years ago

  • Status changed from Feedback to Resolved

This seems to be OK now. The comp-noadapt change was confirmed to work on an affected system (remote client had no LZO compiled in)

Actions #4

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.0 to 2.3.3
Actions

Also available in: Atom PDF