Project

General

Profile

Bug #6744

Picture Widget loses config / actual picture intermittent. Especially when moving from column 2 to 3.

Added by Dan Lundqvist almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Dashboard
Target version:
-
Start date:
08/26/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
All

Description

I have managed to reproduce a problem, somewhat intermittent but frequent,
with Picture Widget where the picture is suddenly lost when the widget is
moved to other column (in this case from 2 to 3).

Have tried on both FF and Chrome with same result and also tried to clear cache inbetween.

See attache screenshots.

1. I add a Picture Widget and selects a jpg file and then press upload. Uploaded OK. (See FF_OK.jpg screenshot)
2. I select the picture widget from column 2 and drag it with mouse to column 3. Now still the picture is seen.
3. When I press the "save widget" button the picture is now gone. (See FF.jpg and Chrome.jpg)

Dan Lundqvist
Stockholm, Sweden

FF_OK.jpg (328 KB) FF_OK.jpg Dan Lundqvist, 08/26/2016 01:01 PM
FF.jpg (278 KB) FF.jpg Dan Lundqvist, 08/26/2016 01:01 PM
Chrome.jpg (242 KB) Chrome.jpg Dan Lundqvist, 08/26/2016 01:01 PM

History

#1 Updated by Dan Lundqvist almost 4 years ago

I also checked the the exported config.xml and I could see that when the fault occurs, the following is missing
<picturewidget> ...
<picturewidget_filename>FB_IMG_1470762718438.jpg</picturewidget_filename>

So it seems to loose these settings.

//Danne

#2 Updated by Dan Lundqvist almost 4 years ago

I now saw that it looses picture config even when a totally separate widget is moved and saved.

//Danne

#3 Updated by Phillip Davis almost 4 years ago

That is fixed by Redmine 6669. It should all work in 2.3.3-DEVELOPMENT snapshots already.

#4 Updated by Dan Lundqvist almost 4 years ago

Then if it's already handled for 2.3.3 this bugreport could be closed.

#5 Updated by Jim Pingle almost 4 years ago

  • Status changed from New to Duplicate
  • Target version deleted (2.3.2-p1)
  • Affected Version deleted (2.3.2)

Duplicate of #6669

Also available in: Atom PDF