Project

General

Profile

Bug #6820

Configure WAN Interface Boot Delay

Added by NOYB NOYB 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Category:
Interfaces
Target version:
Start date:
09/28/2016
Due date:
% Done:

0%

Affected version:
2.4
Affected Architecture:

Description

DHCP server responds within just a few milliseconds, but boot up hangs on configure WAN interface for 20+ seconds. The interface is active and responding to traffic during this time of delay with no firewall rules activated. Totally open system.

Same config on 2.3.3 i386 continues right on through without delay.

Forum Thread:
https://forum.pfsense.org/index.php?topic=118150.0

History

#1 Updated by Jim Pingle 10 months ago

I have seen this as well, though I haven't yet attempted to narrow it down.

#2 Updated by Jim Pingle 10 months ago

  • Status changed from New to Confirmed

#3 Updated by Jim Pingle 10 months ago

At least on my box, I've narrowed it down to the call to dhclient at source:src/etc/inc/interfaces.inc#L4281

Only suspicious thing in the dhclient error output is:

igb1: no link ...... got link

If I kill it and run it manually, it works immediately. Only at bootup does it appear to hesitate. From the message, I'd guess that the physical link isn't showing as up right away, but there is no related console message about the link coming up at the time, either.

#4 Updated by Jim Thompson 8 months ago

  • Assignee set to Jim Thompson

#5 Updated by Renato Botelho 6 months ago

  • Status changed from Confirmed to Feedback

I was seeing this issue on all my test VMs too but on recent snapshots it seems to be OK, probably some change have fixed it. Leaving it in feedback state for now to hear from more people

#6 Updated by Renato Botelho 6 months ago

  • Assignee changed from Jim Thompson to Renato Botelho

#7 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to Resolved

I'm also not seeing a long delay any more. I suspect the fix for #7042 might have also fixed this. The previous delay could have been waiting on the failing DNS request from that problem.

Also available in: Atom PDF