Project

General

Profile

Bug #6929

Choosing ZFS during install results in a system that cannot mount root

Added by Jim Pingle almost 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Category:
Installer
Target version:
Start date:
11/14/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:
All

Description

Choosing the ZFS option results in a system that starts to boot, but cannot mount the root slice because it doesn't know ZFS.

Trying to mount root from zfs:zroot/ROOT/default []...
Mounting from zfs:zroot/ROOT/default failed with error 2: unknown file system

I can force it to mount by running the following at a loader prompt:

load /boot/kernel/kernel
load /boot/kernel/opensolaris.ko
load /boot/kernel/zfs.ko

If I then edit loader.conf and add lines to load the modules, it will boot automatically:

opensolaris_load="YES" 
zfs_load="YES" 

History

#1 Updated by Renato Botelho almost 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Pushed a fix, please try next round of snapshots

#2 Updated by Jim Pingle almost 3 years ago

  • Status changed from Feedback to Resolved

ZFS now works on CE and Factory snapshots, thanks!

#3 Updated by Satadru Pramanik about 1 year ago

FYI this situation is re-occurring on current 2.4.4 dev snapshots. (The problem started in the last week.)

It can be fixed with the workaround above and the aforementioned additions to /boot/loader.conf, which unfortunately currently get overwritten on updates to newer snapshots.

#4 Updated by Renato Botelho about 1 year ago

Satadru Pramanik wrote:

FYI this situation is re-occurring on current 2.4.4 dev snapshots. (The problem started in the last week.)

It can be fixed with the workaround above and the aforementioned additions to /boot/loader.conf, which unfortunately currently get overwritten on updates to newer snapshots.

I've pushed a fix to prevent update to overwrite loader.conf

#5 Updated by Satadru Pramanik about 1 year ago

Renato Botelho wrote:

I've pushed a fix to prevent update to overwrite loader.conf

Thanks.

As a point of clarification, should the following be in the loader.conf by default?

opensolaris_load="YES"
zfs_load="YES"

#6 Updated by Victor Hooi about 1 year ago

I hit this issue as well.

The workaround was to trigger the loader mode on bootup, then enter the commands:

load /boot/kernel/kernel
load /boot/kernel/opensolaris.ko
load /boot/kernel/zfs.ko
boot

However, the above comment seems to imply this is fixed - however, I've just updated to the 2018-07-21 nightly build, and it's still hanging on boot with "Mounting from zfs:zroot/ROOT/default failed with error 2: unknown file system".

Is this expected?

Or is the latest build meant to fix this issue automatically, or are we meant to do something manually to fix the issue?

#7 Updated by Jim Thompson about 1 year ago

Victor Hooi wrote:

I hit this issue as well.

The workaround was to trigger the loader mode on bootup, then enter the commands:

load /boot/kernel/kernel
load /boot/kernel/opensolaris.ko
load /boot/kernel/zfs.ko
boot

However, the above comment seems to imply this is fixed - however, I've just updated to the 2018-07-21 nightly build, and it's still hanging on boot with "Mounting from zfs:zroot/ROOT/default failed with error 2: unknown file system".

Is this expected?

Or is the latest build meant to fix this issue automatically, or are we meant to do something manually to fix the issue?

does your /boot/loader.conf contain

opensolaris_load="YES"
zfs_load="YES"

??

#8 Updated by Jim Pingle about 1 year ago

If you upgraded to a snapshot that clobbered your /boot/loader.conf contents then you would need to re-add the zfs_load="YES" line to /boot/loader.conf manually. Those upgrading from before the problem time to now will be OK. Those upgrading from the problematic snapshots who repaired their loader.conf will be OK.

#9 Updated by Satadru Pramanik about 1 year ago

Jim Pingle wrote:

If you upgraded to a snapshot that clobbered your /boot/loader.conf contents then you would need to re-add the zfs_load="YES" line to /boot/loader.conf manually. Those upgrading from before the problem time to now will be OK. Those upgrading from the problematic snapshots who repaired their loader.conf will be OK.

Thanks.

I googled the error when I first saw this problem, saw this thread, and added

opensolaris_load="YES"
zfs_load="YES"

to my loader.conf, and since it is being preserved, I've had no further problems (with this) since...

#10 Updated by Victor Hooi about 1 year ago

Got it - thanks for clarifying, Jim.

I added those two lines to the bottom of my /boot/loader.conf:

opensolaris_load="YES"
zfs_load="YES"

However, you're saying I only need the zfs_load line, right? I can take out the opensolaris_load line.

The joys of living on the bleeding edge, haha.

#11 Updated by Jim Pingle about 1 year ago

Having both won't hurt anything, but you only need zfs_load="YES" in loader.conf

Also available in: Atom PDF