Project

General

Profile

Bug #6972

"Are you sure you wish to?" prompts and other issues with deleting networks from network-type aliases

Added by Kill Bill 6 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
11/29/2016
Due date:
% Done:

50%

Affected version:
2.3.x
Affected Architecture:
All

Description

I randomly keep getting a nonsensical "Are you sure you wish to?" prompt when deleting networks from network-type aliases. It's completely random. Trying to delete the same thing will produce the prompt one time, next time i won't, then another row will produce the prompt, sometimes it does not happen at all, sometimes I'm unable to delete anything without prompt.

Additionally, sometimes clicking the Delete button has absolutely no effect, the row simply won't delete no matter what. Need to drill back to the alias from Firewall - Aliases, ... then it works.

Huh?!

Associated revisions

Revision fab3c245
Added by Steve Beaver 5 months ago

Fixed #6972
I was only able to reproduce tis issue using Chrome, but it should now be resolved

Revision d9f1170e
Added by Steve Beaver 5 months ago

Fixed #6972
I was only able to reproduce tis issue using Chrome, but it should now be resolved

History

#1 Updated by Kill Bill 6 months ago

An example:

#2 Updated by Kill Bill 6 months ago

OK, after a bit of clicking, this is definitely not limited to aliases, let alone network-type ones. I managed to get this randomly with other types of aliases, or with NTP/ACLs (also see Bug #6984 for other results with Delete button). Appears to me the entire rowhelper thing needs major refactoring.

#3 Updated by Steve Beaver 5 months ago

  • Assignee set to Steve Beaver

#4 Updated by Renato Botelho 5 months ago

  • Status changed from New to Confirmed

I've found the way to reproduce it. It happens when you click on fa-trash icon. If you click on other areas of the button confirmation is not asked, but if you click exactly on trash icon it triggers the pop up.

#5 Updated by Kill Bill 5 months ago

Renato Botelho wrote:

It happens when you click on fa-trash icon. If you click on other areas of the button confirmation is not asked, but if you click exactly on trash icon it triggers the pop up.

Indeed. Also, with this hint, I have discovered that the "sometimes clicking the Delete button has absolutely no effect" happens when
- you add a couple of rows, e.g. in Aliases - using the Add Host/Add Network button
- after that, you click on the fa-trash icon to delete those rows again - nothing happens there, funny enough, not even the "Are you sure you wish to?" popup that appears on rows that already existed before the "Edit" action.

#6 Updated by Steve Beaver 5 months ago

I'll take care of it :)

#7 Updated by Steve Beaver 5 months ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Kill Bill

I am only able to reproduce this with Chrome but it should now be resolved.

#8 Updated by Steve Beaver 5 months ago

  • % Done changed from 0 to 100

#9 Updated by Kill Bill 5 months ago

OK, got to testing. As a good news, the annoying prompt is gone. The second symptom (unable to delete added rows when clicking on the fa-trash icon) definitely persists.

#10 Updated by Renato Botelho 5 months ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Kill Bill to Steve Beaver
  • % Done changed from 100 to 50

#11 Updated by Steve Beaver 5 months ago

  • Assignee changed from Steve Beaver to Renato Botelho

I am unable to reproduce this in the updated version. Clicking the trash can icon previously did not delete for me, but it does now (in Chrome and all other tested browsers)

Would you please make sure that this is not a cache problem?

This is the change that fixed it for me:

src/usr/local/www/js/pfSenseHelpers.js
@ -375,9 +375,9 @
$('[id^=delete]').click(function(event) {
if ($('.repeatable').length > 1) {
if ((typeof retainhelp) == "undefined")
- moveHelpText(event.target.id);
+ moveHelpText($(this).attr("id"));

- delete_row(event.target.id);
+ delete_row($(this).attr("id"));
} else {
alert('The last row may not be deleted.');
}

#12 Updated by Kill Bill 5 months ago

To reproduce:

1/ Edit some alias
2/ Add some rows
3/ Now, try to delete them (or the previously existing rows) by clicking on the fa-trash icon.

#13 Updated by Renato Botelho 5 months ago

  • Assignee changed from Renato Botelho to Steve Beaver

#14 Updated by Steve Beaver 5 months ago

  • Assignee changed from Steve Beaver to Renato Botelho

Fixed. Please retest.

#15 Updated by Kill Bill 5 months ago

Looks all good here. Thanks. ;)

#16 Updated by Renato Botelho 5 months ago

  • Status changed from Assigned to Resolved

#17 Updated by Jim Pingle 3 months ago

  • Target version changed from 2.4.0 to 2.3.3

#18 Updated by Kill Bill about 1 month ago

Renato Botelho wrote:

I've found the way to reproduce it. It happens when you click on fa-trash icon. If you click on other areas of the button confirmation is not asked, but if you click exactly on trash icon it triggers the pop up.

Has this ever been backported to 2.3.x? I don't think so, still see the button do nothing with 2.3.4 snaps when you click on the icon (plus another issue with NTP at https://redmine.pfsense.org/issues/6984)

Also available in: Atom PDF