Project

General

Profile

Actions

Bug #699

closed

html escaping problem in alias member description

Added by Jesse Norell over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
06/25/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

Alias member descriptions seem to not be escaped, eg. I have a network alias with a cidr block member, if the description contains an apostrophe like "Jesse's house" it is not escaped. It gives an error in the browser error console and breaks the ui (specifically the mouseover pop-up box is not displayed).

This is on:

2.0-BETA2
built on Fri Jun 11 11:21:19 EDT 2010
FreeBSD 8.1-PRERELEASE

Actions #1

Updated by Scott Ullrich over 11 years ago

Hi, could you clarify what screen this is on.. The Dashboard?

Actions #2

Updated by Erik Fonnesbeck over 11 years ago

Sounds like any rules list displaying a rule with the alias.

Actions #3

Updated by Jesse Norell over 11 years ago

Correct, this is seen under Firewall -> Rules. I just tested with a host alias, same problem. To reproduce:

  • create a host or network alias
  • add member to that alias with an apostrophe in the description
  • add a firewall rule with that alias

Then in the list of firewall rules, the mouseover pop-up that normally shows the alias members won't display.

Actions #4

Updated by Chris Buechler over 11 years ago

  • Status changed from New to Closed

this was fixed since your version, which is over a month old. Please update to the latest before filing reports, things change very rapidly.

Actions

Also available in: Atom PDF