Project

General

Profile

Bug #7153

pkg-utils.inc - register_all_installed_packages() does not handle packages that are missing XML

Added by Kill Bill over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Package System
Target version:
Start date:
01/22/2017
Due date:
% Done:

100%

Affected Version:
2.3.x
Affected Architecture:
All

Description

After seeing "Running last steps of Status_Traffic_Totals installation" on every reboot, I did some digging into the issue and found that register_all_installed_packages() tries to run install_package_xml($pkg['name']) - there's no such thing shipped with net/pfSense-pkg-Status_Traffic_Totals

History

#1 Updated by Jim Thompson over 1 year ago

  • Assignee set to Jared Dillard

#2 Updated by Renato Botelho 10 months ago

  • Target version changed from 2.4.0 to 2.4.1

#3 Updated by Jim Pingle 9 months ago

  • Target version changed from 2.4.1 to 2.4.2

#4 Updated by Jim Pingle 9 months ago

  • Target version changed from 2.4.2 to 2.4.3

#5 Updated by Jared Dillard 5 months ago

  • Status changed from New to Feedback

#6 Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Assigned

The files look like they are all there but I am still not getting a <package> tag in config.xml for Status_Traffic_Totals when I upgrade or remove and install it again.

#7 Updated by Renato Botelho 5 months ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

It was missing to enable install / deinstall scripts, which are responsible to call PHP code that registers it on the system. I've pushed a fix and bumped version to 1.2.4

#8 Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Resolved

Works great now, thanks!

Also available in: Atom PDF