Project

General

Profile

Bug #721

captive portal error

Added by Cristian Astorino about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
07/05/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

I installed pfsense 2.0-BETA3 built on Sun Jul 4 07:31:59 EDT 2010.
I configured it in my virtual machine to test my future setup. Installation worked fine.
I configured lan and wan and firewall. I added a "test" user in user manager. Then I enabled captive portal, but when opening the browser from an host connected to the lan, I obtain the following error:

Fatal error: Call to undefined function display_error_form() in /etc/inc/auth.inc on line 56

and so, the captive portal doesn't works.

Let me know if you need configuration files or other.
Regards

Associated revisions

Revision 0321fa1b (diff)
Added by Jim Pingle about 9 years ago

Wrap the dns rebind check in a test to see if our error function exists. If it doesn't, it's probably being called from captive portal, so skip the check. Fixes #721

History

#1 Updated by Chris Buechler about 9 years ago

  • Target version set to 2.0

#2 Updated by Jim Pingle about 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Cristian Astorino about 9 years ago

OK, I tried the fix suggested and it works fine.

But now I found two other problems:

- authentication with User Manager doesn't work ( always get invalid id/pass ); but I think is related to a problem in user manager, because I installed freeradius and authentication is OK.

- I checked "Enable logout popup window" in captive portal config, but after login is ok, the popup is not opened. I'm using chromium browser. Do I should open another ticket for this?

Regards

#4 Updated by Jim Pingle about 9 years ago

Both of those could be specific to your configuration settings, so it's hard to say. I would post in the forum first to see if anyone else has those errors. Either that, or new tickets, but I would confirm first that it is not just a settings issue.

#5 Updated by Cristian Astorino about 9 years ago

About the user manager problem, I see an open ticket that reproduce my problem; shortly when adding an user, it's created a group with no name and it cannot be deleted... etc. User Manager has no config, so I doubt is a config issue because I installed freeradius and configured with captive portal and it works fine, so I think there are some bug in user manager.
For the secondo "bug", in captive portal config I checked "Enable logout popup window" and I cannot see other option that could interfere with that. I only tested this with Chromium browser on ubuntu, I will try to test it with others browsers and other os.

Regards

#6 Updated by Jim Pingle about 9 years ago

  • Status changed from Feedback to Resolved

That other user manager bug has been fixed, so you may want to wait for a new snapshot to come up, install it, and then see if you can reproduce any of the errors.

The bug in this original ticket has been fixed, so update the other ticket (or make a forum post) if you can still reproduce errors after the next snapshot.

#7 Updated by Erik Fonnesbeck about 9 years ago

Make sure your web browser is not blocking the popup. It will do that by default in any modern browser (but not as visible in Chromium).

Also available in: Atom PDF