Project

General

Profile

Bug #7254

Selection from long tab list that uses dropdown does not POST correctly

Added by Phillip Davis 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
02/12/2017
Due date:
% Done:

0%

Affected version:
2.4
Affected Architecture:

Description

1) Have a lot of interfaces with long names.
2) Got to Firewall->Rules
3) Try to access the rules of a different interface by selecting form the dropdown list of interfaces.

Expected behavior: The rules of the selected interface are displayed

Actual behavior: The riles of the WAN interface are always displayed

History

#1 Updated by Phillip Davis 7 months ago

PR https://github.com/pfsense/pfsense/pull/3533 provides a fix that works for me. It will at least get functionality back for people who have this issue. It needs proper review to work out the best way this should be coded in the underlying JavaScript infrastructure.

#2 Updated by Jim Thompson 7 months ago

  • Status changed from New to Assigned
  • Assignee set to Steve Beaver

#3 Updated by Steve Beaver 7 months ago

  • Status changed from Assigned to Feedback

Fixed via Phil D PR

#4 Updated by James Dekker 6 months ago

Could not reproduce this on 2.4.0.b.20170401.1306 with twelve interfaces configured

#5 Updated by Jim Pingle 6 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF