Project

General

Profile

Bug #7268

System Info Widget "All" button does not work with "Disable the automatic dashboard auto-update check"

Added by Phillip Davis 7 months ago. Updated 6 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Start date:
02/17/2017
Due date:
% Done:

0%

Affected version:
2.3.3
Affected Architecture:

Description

1) In System, Update, Settings, select "Disable the automatic dashboard auto-update check"
2) On the dashboard, click the "tool wrench" for the System Information widget
3) Deselect some items and save - the widget now displays less rows of information - good.
4) On the dashboard, click the "tool wrench" for the System Information widget again
5) Click the "All" button

Expected behavior: All items are selected

Actual behavior: Nothing happens

History

#1 Updated by Phillip Davis 7 months ago

Note: "Disable the automatic dashboard auto-update check" is often selected on nanoBSD installs, so nanoBSD users might notice this reasonably obscure bug. The workaround is just to manually select all the items, rather than using the "All" button.

PR to fix: https://github.com/pfsense/pfsense/pull/3550

#2 Updated by Renato Botelho about 2 months ago

  • Status changed from New to Feedback

Merged

#3 Updated by Jim Pingle 6 days ago

  • Status changed from Feedback to Resolved

Looks good, on SG-1000 I have the auto update check disabled and the JS all/none selector still works for me in the system info widget options.

Also available in: Atom PDF