Project

General

Profile

Bug #733

Shaper: Unexplained 30% bandwidth max restriction in p2p catch all

Added by Josh Stompro about 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
07/12/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When going through the traffic_shaper_wizard_multi_all.xml wizard and trying to set the p2p catch all bandwidth to anything higher than 30%, the wizard eventually kicks you back to the voip settings page with an error about how the custom bandwidths cannot exceed 30%. If this is a real limit and not a bug it would be helpful if it was stated in the wizard up front rather than as a not directly related error message.

Error Message "Custom Bandwidths are greater than 30%. Please lower them for the wizard to continue."

Tested on 2.0-BETA3
built on Sun Jul 11 23:57:27 EDT 2010
FreeBSD 8.1-RC1 nanobsd 2g

Steps to reproduce:
  1. Firewall->traffic Shaper
  2. Wizard tab
  3. Select traffic_shaper_wizard_multi_all.xml
  4. Go through wizard and select the usual options.
  5. When you get to the Peer to Peer networking screen, Enable, p2pCatchAll: check, Bandwidth: 50%, click next.
  6. Go through the rest of the wizard, when you click finish it will take you back to the VOIP settings screen with the error "Custom Bandwidths are greater than 30%. Please lower them for the wizard to continue.".

Ermal requested ticket be created in form post.
http://forum.pfsense.org/index.php/topic,26195.msg136384.html#msg136384

This issue is also mentioned in Bug #302.
http://redmine.pfsense.org/issues/302

Thanks
Josh

Associated revisions

Revision b9d017f5 (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #733. Provide a description that custom bandwidths cannot exceed 30% of entered bandwidths for interfaces/links.

History

#1 Updated by Chris Buechler about 9 years ago

  • Target version set to 2.0

#2 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#3 Updated by Josh Stompro over 8 years ago

I have few more questions about this issue.

Is the user just supposed to know that custom bandwidths = p2p catchall bandwidths, and/or VOIP bandwidths. Since the wizard does not use the term custom bandwidths, how is the user supposed to figure that out?

Why is the wizard returning to the VOIP settings screen when the problem was with the P2P catch all bandwidth?
Thanks
Josh

#4 Updated by Ermal Luçi over 8 years ago

Its just a reload of the settings that take part in the les than 30% calculation.

#5 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF