Project

General

Profile

Bug #7343

On 2.3.3, Updater reports that the latest version is 0.18_1

Added by brennen smith over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
03/02/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.3
Affected Architecture:
amd64

Description

On pfSense 2.3.3, we are occasionally seeing that the UI is retrieving the latest version of pfSense as 0.18_1 and does provide the ability to "upgrade"

This is on the stable path, no changes made to the update settings.

I looked in the logs, but did not see anything out of the ordinary or references to the updater. If there's any logs I can pull, let me know.

An example of the homepage widget: http://ookla.d.pr/NIPj
An example of the actual settings page: http://ookla.d.pr/6dMja

History

#1 Updated by brennen smith over 2 years ago

Updated example of the homepage widget (previous version exposed PII): http://ookla.d.pr/rHOW
Example of the actual settings page: http://ookla.d.pr/120HC

#2 Updated by Renato Botelho over 2 years ago

I've pushed a fix on pfSense-upgrade 0.19.

pfSense-upgrade was considering its new version as a new firmware version. The issue is harmless and if you finish the upgrade nothing bad will happen.

Fix is on version 0.19. As soon as it's available it's safe to manually run 'pkg upgrade pfSense-upgrade' on console to go to latest verssion

#3 Updated by Will Wainwright over 2 years ago

Hi guys,

I don't know if this is related or not, but thought I'd throw it out.

I have a vm running 2.3.3. I overshot the release and ran 2.3.4 for a couple of days, but I gitsynced back to 2.3.3 per this post:

https://208.123.73.18/index.php?topic=125660.msg694105#msg694105

it came back up & reported 2.3.3. Only thing was when I checked for updates I still got a 2.3.4 version number. I just checked the updater & now it's offering me version ".20".

-Will

#4 Updated by Denny Page over 2 years ago

I also see an issue on factory 2.3.3. I see "The system is on a later version than the official release" in the system widget. If I go into System / Update, I am shown "0.20" as the latest base version.

#5 Updated by Mark Jeremy over 2 years ago

I have the XG-1540 with 10GB addon NIC and I'm seeing the same thing as Denny Page

System Information page:

System / Update page:

#6 Updated by Kill Bill over 2 years ago

Yeah, the answer is still the same. Run pkg upgrade pfSense-upgrade from shell.

#7 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Resolved
  • Assignee set to Renato Botelho
  • Target version set to 2.3.3-p1

Also available in: Atom PDF