Project

General

Profile

Bug #7500

Upgrade From 2.3.3_p1 to 2.4 Fails (libssl.so.8 not found)

Added by ryon m about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
04/28/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.3
Affected Architecture:
amd64

Description

Existing installs and fresh installs of 2.3.3 & 2.3.3_p1 fail upgrade to 2.4 with the following errors:

Shared object "libssl.so.8" not found, required by "pkg"
Shared object "libssl.so.8" not found, required by "pkg"
ERROR: It was not possible to identify which pfSense kernel is installed

See the following forum postings for more info:

https://forum.pfsense.org/index.php?topic=129641.0

https://forum.pfsense.org/index.php?topic=129310.0

History

#1 Updated by ryon m about 2 years ago

Sorry - Affected version is 2.3.3 & 2.3.3_p1, not 2.2.3.

#2 Updated by Jim Pingle almost 2 years ago

See also: #7722

#3 Updated by Renato Botelho almost 2 years ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Affected Version changed from 2.2.3 to 2.3.3

Whatever happened at this point seems to be fixed now. I did several upgrades last days and all of them worked.

#4 Updated by ryon m over 1 year ago

I'm no longer seeing this error on recent upgrades, please close the ticket.

For documentation, the following commands were used to recover from the error:

pkg-static update –f
pkg-static upgrade –f

The following did not work:

pkg update -f
pkg upgrade -f

or

Upgrade from Console (Option 13)

#5 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF