Project

General

Profile

Bug #7629

FreeBSD PR affecting pfsense

Added by Chris Collins over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
06/06/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4
Affected Architecture:
amd64

Description

IS it possible to test the patch on a build of PFSense 2.4 which I am willing to test.

The patch is here

https://people.freebsd.org/~mjg/patches/rwlock-debug.diff

I have submitted the last 2 panic's on the submit button.

Link to FreeBSD PR is here

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=213903

My post on the pfsense forum here.

https://forum.pfsense.org/index.php?topic=123470.new#new

History

#1 Updated by Chris Collins over 2 years ago

Affected version is 2.4 built on Wed Mar 15 18:17:17 CDT 2017
FreeBSD 11.0-RELEASE-p8

#2 Updated by Chris Collins over 2 years ago

another one and again turnstile_broadcast

db:0:kdb.enter.default> bt
Tracing pid 65385 tid 100750 td 0xfffff80016e7c000
turnstile_broadcast() at turnstile_broadcast+0x9c/frame 0xfffffe0113c4f480
__rw_wunlock_hard() at __rw_wunlock_hard+0x8f/frame 0xfffffe0113c4f4b0
vm_map_delete() at vm_map_delete+0x3dc/frame 0xfffffe0113c4f530
vm_map_remove() at vm_map_remove+0x47/frame 0xfffffe0113c4f560
exec_new_vmspace() at exec_new_vmspace+0x22f/frame 0xfffffe0113c4f5e0
exec_elf64_imgact() at exec_elf64_imgact+0xa58/frame 0xfffffe0113c4f6f0
kern_execve() at kern_execve+0x74d/frame 0xfffffe0113c4fa50
sys_execve() at sys_execve+0x4a/frame 0xfffffe0113c4fad0
amd64_syscall() at amd64_syscall+0x4ce/frame 0xfffffe0113c4fbf0
Xfast_syscall() at Xfast_syscall+0xfb/frame 0xfffffe0113c4fbf0
--- syscall (59, FreeBSD ELF64, sys_execve), rip = 0x800b40d8a, rsp = 0x7fffffffe7a8, rbp = 0x7fffffffe8f0 ---

I would appreciate it if this could be done.

#3 Updated by Chris Collins over 2 years ago

An update, I pulled the Freebsd-src from the repo and have actually now compiled the kernel patched and have it running, I will report back here if the panic's stop. :)

#4 Updated by Chris Collins over 2 years ago

All fixes are in 11.1 and 11-STABLE.

So if pfsense 2.4 migrates to 11.1 in july this will be fixed as well as many other nasty bugs, traditionally .0 FreeBSD releases have not been great.

https://www.freebsd.org/releases/11.1R/schedule.html

#5 Updated by Chris Collins about 2 years ago

Since JimP has confirmed 2.4.x will move to 11.1 then this bug is effectively resolved "after" that change occurs.

#6 Updated by Renato Botelho about 2 years ago

  • Priority changed from High to Normal
  • Target version set to 2.4.1

#7 Updated by Jim Pingle about 2 years ago

  • Category set to Operating System
  • Status changed from New to Resolved
  • Target version changed from 2.4.1 to 2.4.0
  • Affected Version set to 2.4

Moving target to 2.4.0 as this appears to be fixed by FreeBSD 11.1, which is now used by 2.4.0

Also available in: Atom PDF