Project

General

Profile

Bug #7645

SG-1000 VLAN interfaces do not work without promisc mode

Added by Jim Pingle over 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Interfaces
Target version:
Start date:
06/13/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4
Affected Architecture:
SG-1000

Description

On the latest snapshot, VLAN interfaces do not function on SG-1000 units unless the parent NIC is set promiscuous (manually with @ifconfig cpsw0 promisc) or by running a program that puts the interface in promisc mode)

It was working on snapshots a few days prior. Latest snapshot is from the 10th, which is also a few days behind.

History

#2 Updated by Jim Pingle over 2 years ago

  • Status changed from Confirmed to Resolved

Fixed in current snapshots

#3 Updated by Christian Carrier about 2 years ago

Upgraded to latest release candidate
2.4.0-RC (arm)
built on Thu Oct 05 21:17:11 CDT 2017
FreeBSD 11.1-RELEASE-p1

And this seems to have caused the issue again on my SG-1000

#4 Updated by Luiz Souza about 2 years ago

Fixed in the latest snapshot.

#5 Updated by Jim Pingle about 2 years ago

Confirmed. VLANs are functional again on the latest snapshot without needing to use promisc mode.

#6 Updated by Pawel Karoluk about 1 year ago

Has this issue been resolved? I have the same problem in the latest stable version of my SG-1000:

2.4.3-RELEASE-p1 (arm)
built on Thu May 10 15:59:52 CDT 2018
FreeBSD 11.1-RELEASE-p10

#7 Updated by Jim Pingle about 1 year ago

This specific issue was resolved over a year ago. If you are having an issue, it's not likely to be this problem.

Please post on the forum or pfSense subreddit with more detail.

#8 Updated by Pawel Karoluk about 1 year ago

After forcing promisc on cpsw1 vlan routing starts working so it seems the same as the issue from the ticket.
I can provide more details but you have tell what exactly you need.

#9 Updated by Jim Pingle about 1 year ago

The symptoms may be similar but the issue is not the same. Post to the forum or pfSense subreddit to discuss in detail.

Also available in: Atom PDF