Project

General

Profile

Todo #7762

Add uid check to pfSense-upgrade and exit unless it is run as uid=0

Added by Jim Pingle 11 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
08/09/2017
Due date:
% Done:

100%


Description

Running pfSense-upgrade as a non-root/admin user will produce errors that are not obviously related to lacking privileges to run it. As a courtesy to the user, it should exit if it is not being run by uid=0. That should cover it being run by root, admin, or via sudo.

History

#1 Updated by Jim Pingle 9 months ago

  • Target version changed from 2.4.1 to 2.4.2

Moving target to 2.4.2 as we need 2.4.1 sooner than anticipated.

#2 Updated by Jim Thompson 9 months ago

  • Assignee set to Renato Botelho

#3 Updated by Jim Pingle 9 months ago

  • Target version changed from 2.4.2 to 2.4.3

#4 Updated by Jim Pingle 4 months ago

  • Target version changed from 2.4.3 to 2.4.4

#5 Updated by Renato Botelho 4 months ago

  • Status changed from New to Feedback
  • Target version changed from 2.4.4 to 2.4.3
  • % Done changed from 0 to 100

It was already fixed in commit ee4701adf85a6b5cb2f8d37f5fdeb7a5668eb674 almost a month ago. I forgot to update the ticket

#6 Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Resolved

Works

Also available in: Atom PDF