Project

General

Profile

Bug #7966

Live traffic graphs appear to have sampling errors

Added by Chris Linstruth almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Traffic Graphs
Target version:
Start date:
10/18/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

The Status > Traffic Graphs function and the Traffic Graph widget appear to have a regression (#7515 ? ).

The sampling samples zero then the next sample has about double the traffic resulting in a "sawtooth" appearance. Not necessarily in that order. Can also appear as a double sample followed by a zero sample.

Associated revisions

Revision e00f69c8 (diff)
Added by Stephen Jones almost 2 years ago

Fixed #7966 added a moving average smoothing factor to help out with some of the jagged graphs. Since the quickest update will be every other second this will help make it look smoother. Also added this to the widget and added some functionality to the status page so it can display in two different styles. Setting smoothing to 0 will make the graph the same as before this was added. Raising it will allow for a moving average to be taken into account to smooth out the graphs.

History

#1 Updated by Renato Botelho almost 2 years ago

  • Category set to Traffic Graphs
  • Assignee set to Jared Dillard

#2 Updated by Mike Dziedziela almost 2 years ago

Chris Linstruth wrote:

The Status > Traffic Graphs function and the Traffic Graph widget appear to have a regression (#7515 ? ).

The sampling samples zero then the next sample has about double the traffic resulting in a "sawtooth" appearance. Not necessarily in that order. Can also appear as a double sample followed by a zero sample.

Don't you think that inbound and outbound values are switched ?

for me it looks like I am sending more than downloading:

In/out packets
350543/517806 (93.26 MiB/678.03 MiB)
In/out packets (pass)
350543/517806 (93.26 MiB/678.03 MiB)

which is strange

#3 Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.4.1 to 2.4.2

#4 Updated by Anonymous almost 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#5 Updated by James Dekker almost 2 years ago

On pfSense-CE-memstick-ADI-2.4.2-DEVELOPMENT-amd64-20171108-1340 gitsync'd to master, the smoothing slider is available and helps make the graph more readable.

Looks good, safe to be set to Resolved, I think.

#6 Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF