Project

General

Profile

Bug #797

UI: IPsec Phase 2 edit, Address field active for LAN subnet option

Added by David Szpunar about 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
IPsec
Target version:
Start date:
08/06/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When editing an existing Phase 2 IPsec entry where the "Local Network: Type" field is set to "LAN subnet" already, when the page first loads the "Address" and bit length fields are active rather disabled. Selecting a different option from the Type field dropdown and then selecting LAN subnet again properly disables the Address fields.

Associated revisions

Revision 71880c96 (diff)
Added by Pierre POMES almost 9 years ago

Do not include 'remoteid' javascript functions for mobile ipsec. Ticket #797

History

#1 Updated by David Szpunar about 9 years ago

Forgot to mention, I tested this on current versions of Chrome and IE8. Since it works after reselecting from the dropdown, I assume it's a general logic issue and not a browser-specific bug.

#2 Updated by Chris Buechler about 9 years ago

  • Status changed from New to Feedback

Not seeing that on Chrome nor IE nor Firefox. The js doesn't (and can't AFAIK) disable those until the page is fully loaded, so if you have a slow connection to a remote system it could show them enabled initially until the page fully loads.

#3 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Closed

closed pending info on how to replicate, not seeing that on 6 different installs, with numerous browsers on 4 different client systems.

#4 Updated by David Szpunar about 9 years ago

Emailed you directly Chris.

#5 Updated by Chris Buechler about 9 years ago

  • Status changed from Closed to New

Thanks David, the issue is with mobile IPsec only.

#6 Updated by David Szpunar about 9 years ago

Ahh! I knew I was missing some variable. Glad you were able to narrow it down, you're welcome. But even with the UI niggle, the good news is that IPsec to multiple subnets (two Phase 2 entries) is working great from iPhone and Shrew client! (But only Shrew 2.1.5-release, the 2.1.6-rc2 from Aug. 5th will NOT work with various errors in the pfSense logs and raccoon output on the pfSense console--Phase 1 connects, no traffic passes and Phase 2 continuously fails.) But the stable version works great. The UI niggle is just that, a niggle. I'll leave it to the experts now, but I'm happy to test when there's a fix.

#7 Updated by Pierre POMES almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Problem was due to a javascript issue, only for mobiles. Should be fixed now.

#8 Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF