Project

General

Profile

Bug #8016

1 pfsense out of several shows 2.4.0 available, not 2.4.1

Added by Eduard Rozenberg almost 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
Upgrade
Target version:
-
Start date:
10/26/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
amd64

Description

1 firewall out of several shows 2.4.0 update available, not 2.4.1.
I tried changing update setting to Next Major Version then back to Stable.
I verified the firewall has network connectivity, for ex. auto backups work.

2.3.4-RELEASE-p1 (amd64)
built on Fri Jul 14 14:52:43 CDT 2017
FreeBSD 10.3-RELEASE-p19

Version 2.4.0 is available.

The other firewalls show as expected:

2.3.4-RELEASE-p1 (amd64)
built on Fri Jul 14 14:52:43 CDT 2017
FreeBSD 10.3-RELEASE-p19

Version 2.4.1 is available.

History

#1 Updated by Jim Thompson almost 2 years ago

  • Assignee set to Renato Botelho

#2 Updated by Eduard Rozenberg almost 2 years ago

Followup notes:

  • On the FW with the issue, did update from 2.3.4 to 2.4.0. Success

1) After reboot, Dashboard update checker shows 2.4.1 is available

2) Went to do the 2.4.1 update. Update page showed "2.4.0" is latest

3) Tried CLI upgrade - option 13 from menu. Got error:
Error Another instance is already running... Aborting!"

4) After some time Dashboard showed:
2.4.1-RELEASE (amd64)
FreeBSD 11.1-RELEASE-p1

But this is not quite ok - 2.4.1 is supposed to show RELEASE-p2

Logged is as ssh root@fw, got "#" prompt instead of menu for some reason
Based on a forum post I ran "pkg-static install -f pfSense-base"
Then rebooted the system.

After reboot, everything looks OK now:
2.4.1-RELEASE (amd64)
built on Sun Oct 22 17:26:33 CDT 2017
FreeBSD 11.1-RELEASE-p2

And also after reboot ssh root@fw again gives the menu

All set now. Conclusion: no idea what the problem was.
It seems 2.4.0 -> 2.4.1 upgrade did work but it definitely
needed a reboot (an automatic reboot did not happen
after 2.4.0 -> 2.4.1 upgrade).

Also don't know if the command I ran:
pkg-static install -f pfSense-base
made any difference (I'm guessing no).

#3 Updated by Jim Pingle about 1 month ago

  • Status changed from New to Closed

Probably an issue with the local pkg environment. We have several documented workarounds in the upgrade guide for how to correct these kinds of local issues.

Also available in: Atom PDF